aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/image/generic.mk
diff options
context:
space:
mode:
authorMatthias Schiffer <mschiffer@universe-factory.net>2018-01-12 16:36:13 +0100
committerMatthias Schiffer <mschiffer@universe-factory.net>2018-01-13 19:54:45 +0100
commit0cd5e85e7ad621223b0787e66d8ad20fb2694135 (patch)
treecbd859d17f19d37696696c0e28fe4e58546180b5 /target/linux/ar71xx/image/generic.mk
parent29d126b5c13a8581cbc0961523eb3fd60320111d (diff)
downloadupstream-0cd5e85e7ad621223b0787e66d8ad20fb2694135.tar.gz
upstream-0cd5e85e7ad621223b0787e66d8ad20fb2694135.tar.bz2
upstream-0cd5e85e7ad621223b0787e66d8ad20fb2694135.zip
ar71xx: create new ar71xx/tiny subtarget for 4MB flash devices
This new subtarget sets the small_flash flag and removes unused kernel configuration. small_flash removes KERNEL_KALLSYMS, which saves ~107KB in the default configuration; removing unneeded hardware support from ar71xx/tiny saves another ~18KB (both after LZMA). Signed-off-by: Matthias Schiffer <mschiffer@universe-factory.net>
Diffstat (limited to 'target/linux/ar71xx/image/generic.mk')
-rw-r--r--target/linux/ar71xx/image/generic.mk14
1 files changed, 2 insertions, 12 deletions
diff --git a/target/linux/ar71xx/image/generic.mk b/target/linux/ar71xx/image/generic.mk
index 6829f113a7..89ab1f0291 100644
--- a/target/linux/ar71xx/image/generic.mk
+++ b/target/linux/ar71xx/image/generic.mk
@@ -231,7 +231,7 @@ TARGET_DEVICES += dragino2
define Device/ew-dorin
DEVICE_TITLE := Embedded Wireless Dorin Platform
- DEVICE_PACKAGES := kmod-usb-core kmod-usb-chipidea
+ DEVICE_PACKAGES := kmod-usb-core kmod-usb-chipidea
BOARDNAME = EW-DORIN
CONSOLE := ttyATH0,115200
IMAGE_SIZE = 16000k
@@ -241,7 +241,7 @@ TARGET_DEVICES += ew-dorin
define Device/ew-dorin-router
DEVICE_TITLE := Embedded Wireless Dorin Router Platform
- DEVICE_PACKAGES := kmod-usb-core kmod-usb-chipidea
+ DEVICE_PACKAGES := kmod-usb-core kmod-usb-chipidea
BOARDNAME = EW-DORIN-ROUTER
CONSOLE := ttyATH0,115200
IMAGE_SIZE = 16000k
@@ -597,16 +597,6 @@ define Device/r602n
endef
TARGET_DEVICES += r602n
-define Device/rnx-n360rt
- $(Device/tplink-4m)
- DEVICE_TITLE := Rosewill RNX-N360RT
- BOARDNAME := TL-WR941ND
- DEVICE_PROFILE := RNXN360RT
- TPLINK_HWID := 0x09410002
- TPLINK_HWREV := 0x00420001
-endef
-TARGET_DEVICES += rnx-n360rt
-
define Device/mc-mac1200r
$(Device/tplink-8mlzma)
DEVICE_TITLE := Mercury MAC1200R