aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/image/Makefile
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2016-03-23 12:52:47 +0000
committerJohn Crispin <john@openwrt.org>2016-03-23 12:52:47 +0000
commite0a3a8452153f752cec31ca5d0396697a39bfd4e (patch)
tree92ebe836f290dbaa9a6361ee44e61006d0253798 /target/linux/ar71xx/image/Makefile
parent5bac8f0fd4ae95672ea19b8eb01c8001522107b1 (diff)
downloadupstream-e0a3a8452153f752cec31ca5d0396697a39bfd4e.tar.gz
upstream-e0a3a8452153f752cec31ca5d0396697a39bfd4e.tar.bz2
upstream-e0a3a8452153f752cec31ca5d0396697a39bfd4e.zip
ar71xx/image: allow builds of loader without cmdline injecting
On most platforms the cmdline is supplied by the loader to the kernel. When using an elf loader with cmdline the size is bloated by 512k. For loader-elf platforms like the cpe510 better use loader-elf but patch the cmdline into the kernel. wdr1043: Tested loader still works using sysupgade image. Signed-off-by: Alexander Couzens <lynxis@fe80.eu> SVN-Revision: 49080
Diffstat (limited to 'target/linux/ar71xx/image/Makefile')
-rw-r--r--target/linux/ar71xx/image/Makefile10
1 files changed, 7 insertions, 3 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index 0c8aaa2bfe..507d7506e5 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -78,7 +78,7 @@ define Build/loader-common
$(MAKE) -C lzma-loader \
PKG_BUILD_DIR="$@.src" \
TARGET_DIR="$(dir $@)" LOADER_NAME="$(notdir $@)" \
- KERNEL_CMDLINE="$(CMDLINE)" BOARD="$(BOARDNAME)" \
+ BOARD="$(BOARDNAME)" \
LZMA_TEXT_START=0x80a00000 LOADADDR=0x80060000 \
$(1) compile loader.$(LOADER_TYPE)
mv "$@.$(LOADER_TYPE)" "$@"
@@ -86,13 +86,17 @@ define Build/loader-common
endef
define Build/loader-okli-compile
- $(call Build/loader-common,FLASH_OFFS=$(LOADER_FLASH_OFFS) FLASH_MAX=0)
+ $(call Build/loader-common,FLASH_OFFS=$(LOADER_FLASH_OFFS) FLASH_MAX=0 KERNEL_CMDLINE="$(CMDLINE)")
endef
define Build/loader-kernel
$(call Build/loader-common,LOADER_DATA="$@")
endef
+define Build/loader-kernel-cmdline
+ $(call Build/loader-common,LOADER_DATA="$@" KERNEL_CMDLINE="$(CMDLINE)")
+endef
+
define Build/loader-okli
dd if=$(KDIR)/loader-$(1).gz bs=7680 conv=sync of="$@.new"
cat "$@" >> "$@.new"
@@ -278,7 +282,7 @@ $(Device/tplink)
COMPILE := loader-$(1).gz
COMPILE/loader-$(1).gz := loader-okli-compile
KERNEL := copy-file $(KDIR)/vmlinux.bin.lzma | uImage lzma -M 0x4f4b4c49 | loader-okli $(1)
- KERNEL_INITRAMFS := copy-file $(KDIR)/vmlinux-initramfs.bin.lzma | loader-kernel | mktplinkfw-initramfs
+ KERNEL_INITRAMFS := copy-file $(KDIR)/vmlinux-initramfs.bin.lzma | loader-kernel-cmdline | mktplinkfw-initramfs
endef
define Device/tplink-4m