aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/image/Makefile
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2016-02-12 08:31:32 +0000
committerJohn Crispin <john@openwrt.org>2016-02-12 08:31:32 +0000
commitcede06cebc7678b5d617ab4f64b3b53b8bbe44dc (patch)
tree89c9049a7f0db2067082abaf1c2c60999fa7e81a /target/linux/ar71xx/image/Makefile
parent22f20c4a6690520cfb9b8045a92d21e7974d1e2d (diff)
downloadupstream-cede06cebc7678b5d617ab4f64b3b53b8bbe44dc.tar.gz
upstream-cede06cebc7678b5d617ab4f64b3b53b8bbe44dc.tar.bz2
upstream-cede06cebc7678b5d617ab4f64b3b53b8bbe44dc.zip
ar71xx: Support for Ubiquiti UniFi AP AC LITE
Add support for the Ubiquiti UniFi AP AC LITE Signed-off-by: P.Wassi <p.wassi at gmx.at> SVN-Revision: 48711
Diffstat (limited to 'target/linux/ar71xx/image/Makefile')
-rw-r--r--target/linux/ar71xx/image/Makefile11
1 files changed, 10 insertions, 1 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index 1bb0ac95bc..a77004181d 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -1141,12 +1141,21 @@ define Device/ubnt-unifi
DEVICE_PROFILE := UBNT UBNTUNIFI
endef
+define Device/ubnt-unifiac
+ DEVICE_PROFILE := UBNT UBNTUNIFIAC
+ IMAGE_SIZE := 7744k
+ MTDPARTS = spi0.0:384k(u-boot)ro,64k(u-boot-env)ro,7744k(firmware),7744k(ubnt-airos)ro,128k(bs)ro,256k(cfg)ro,64k(EEPROM)ro
+ IMAGES := sysupgrade.bin
+ IMAGE/sysupgrade.bin = append-kernel $$$$(BLOCKSIZE) | append-rootfs | pad-rootfs | check-size $$$$(IMAGE_SIZE)
+ BOARDNAME := UBNT-UF-AC
+endef
+
define Device/ubnt-unifi-outdoor
$(Device/ubnt-bz)
BOARDNAME := UBNT-U20
DEVICE_PROFILE := UBNT UBNTUNIFIOUTDOOR
endef
-TARGET_DEVICES += ubnt-unifi ubnt-unifi-outdoor
+TARGET_DEVICES += ubnt-unifi ubnt-unifiac ubnt-unifi-outdoor
define Device/ubnt-nano-m-xw
$(Device/ubnt-xw)