aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/image/Makefile
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2016-04-01 07:11:23 +0000
committerJohn Crispin <john@openwrt.org>2016-04-01 07:11:23 +0000
commitc8dd53e591801cb403cc4b916b474e39d65f2214 (patch)
tree8271619f9fe70c2551691cd0cf95cdf7acbc75c6 /target/linux/ar71xx/image/Makefile
parent41ba4b04c84a80a441b30e167eab0d45d3b6c009 (diff)
downloadupstream-c8dd53e591801cb403cc4b916b474e39d65f2214.tar.gz
upstream-c8dd53e591801cb403cc4b916b474e39d65f2214.tar.bz2
upstream-c8dd53e591801cb403cc4b916b474e39d65f2214.zip
ar71xx: Add TL-WR841N/ND v11 support
This patch adds support for the TP-Link TL-WR841N/ND to trunk. It is similar to the already supported v10 - see [1]. I have added support based on that topic; in the meantime it has been confirmed working (see the forum thread, and also [2]). Signed-off by Stijn Segers <francesco.borromini@inventati.org> [1]: https://forum.openwrt.org/viewtopic.php?id=61309 [2]: https://forum.openwrt.org/viewtopic.php?id=63657 SVN-Revision: 49099
Diffstat (limited to 'target/linux/ar71xx/image/Makefile')
-rw-r--r--target/linux/ar71xx/image/Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index 290e85b68d..595fba2deb 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -850,6 +850,13 @@ define Device/tl-wr841-v10
TPLINK_HWID := 0x08410010
endef
+define Device/tl-wr841-v11
+ $(Device/tplink-4mlzma)
+ BOARDNAME := TL-WR841N-v9
+ DEVICE_PROFILE := TLWR841
+ TPLINK_HWID := 0x08410011
+endef
+
define Device/tl-wr842n-v1
$(Device/tplink-8m)
BOARDNAME := TL-MR3420
@@ -877,7 +884,7 @@ define Device/tl-wr847n-v8
DEVICE_PROFILE := TLWR841
TPLINK_HWID := 0x08470008
endef
-TARGET_DEVICES += tl-wr841-v1.5 tl-wr841-v3 tl-wr841-v5 tl-wr841-v7 tl-wr841-v8 tl-wr841-v9 tl-wr841-v10 tl-wr842n-v1 tl-wr842n-v2 tl-wr843nd-v1 tl-wr847n-v8
+TARGET_DEVICES += tl-wr841-v1.5 tl-wr841-v3 tl-wr841-v5 tl-wr841-v7 tl-wr841-v8 tl-wr841-v9 tl-wr841-v10 tl-wr841-v11 tl-wr842n-v1 tl-wr842n-v2 tl-wr843nd-v1 tl-wr847n-v8
define Device/tl-wr941nd-v2
$(Device/tplink-4m)