aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/image/Makefile
diff options
context:
space:
mode:
authorP.Wassi <p.wassi at gmx.at>2016-05-11 09:35:24 +0200
committerJohn Crispin <john@phrozen.org>2016-05-12 03:29:36 +0200
commitc855e70491fbd5d432915c4cbeb3b80f3a117e30 (patch)
treec36b901272e54962737eb861b79722aa229569ad /target/linux/ar71xx/image/Makefile
parentffaaa6788a983a5eae0117d138a297df3f131869 (diff)
downloadupstream-c855e70491fbd5d432915c4cbeb3b80f3a117e30.tar.gz
upstream-c855e70491fbd5d432915c4cbeb3b80f3a117e30.tar.bz2
upstream-c855e70491fbd5d432915c4cbeb3b80f3a117e30.zip
ar71xx: Rename unifiac to unifiac-lite
To avoid confusion with different unifiac devices, rename existing target "unifiac" to "unifiac-lite", before "unifiac-pro" is introduced. Signed-off-by: P.Wassi <p.wassi at gmx.at>
Diffstat (limited to 'target/linux/ar71xx/image/Makefile')
-rw-r--r--target/linux/ar71xx/image/Makefile21
1 files changed, 13 insertions, 8 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index bc8a4a8ec7..dba26672ab 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -1195,6 +1195,14 @@ define Device/ubnt-bz
IMAGE/sysupgrade.bin = append-kernel $$$$(BLOCKSIZE) | append-rootfs | pad-rootfs | check-size $$$$(IMAGE_SIZE)
endef
+define Device/ubnt-unifiac
+ DEVICE_PROFILE := UBNT
+ IMAGE_SIZE := 7744k
+ MTDPARTS = spi0.0:384k(u-boot)ro,64k(u-boot-env)ro,7744k(firmware),7744k(ubnt-airos)ro,128k(bs)ro,256k(cfg)ro,64k(EEPROM)ro
+ IMAGES := sysupgrade.bin
+ IMAGE/sysupgrade.bin = append-kernel $$$$(BLOCKSIZE) | append-rootfs | pad-rootfs | check-size $$$$(IMAGE_SIZE)
+endef
+
define Device/rw2458n
$(Device/ubnt-xm)
BOARDNAME := RW2458N
@@ -1227,13 +1235,10 @@ define Device/ubnt-unifi
DEVICE_PROFILE := UBNT UBNTUNIFI
endef
-define Device/ubnt-unifiac
- DEVICE_PROFILE := UBNT UBNTUNIFIAC
- IMAGE_SIZE := 7744k
- MTDPARTS = spi0.0:384k(u-boot)ro,64k(u-boot-env)ro,7744k(firmware),7744k(ubnt-airos)ro,128k(bs)ro,256k(cfg)ro,64k(EEPROM)ro
- IMAGES := sysupgrade.bin
- IMAGE/sysupgrade.bin = append-kernel $$$$(BLOCKSIZE) | append-rootfs | pad-rootfs | check-size $$$$(IMAGE_SIZE)
- BOARDNAME := UBNT-UF-AC
+define Device/ubnt-unifiac-lite
+ $(Device/ubnt-unifiac)
+ DEVICE_PROFILE := UBNT UBNTUNIFIACLITE
+ BOARDNAME := UBNT-UF-AC-LITE
endef
define Device/ubnt-unifi-outdoor
@@ -1241,7 +1246,7 @@ define Device/ubnt-unifi-outdoor
BOARDNAME := UBNT-U20
DEVICE_PROFILE := UBNT UBNTUNIFIOUTDOOR
endef
-TARGET_DEVICES += ubnt-unifi ubnt-unifiac ubnt-unifi-outdoor
+TARGET_DEVICES += ubnt-unifi ubnt-unifiac-lite ubnt-unifi-outdoor
define Device/ubnt-nano-m-xw
$(Device/ubnt-xw)