aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/image/Makefile
diff options
context:
space:
mode:
authorSungbo Eo <mans0n@gorani.run>2020-03-09 21:14:06 +0900
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-03-11 18:25:06 +0100
commit90daff4cf8a86622012217d3be7ce136c313a896 (patch)
tree5c42cb53114f8953a58327bb3980bbb40423c579 /target/linux/ar71xx/image/Makefile
parent14a07fa1f000f962d55bf53cfe9b128448b1f11f (diff)
downloadupstream-90daff4cf8a86622012217d3be7ce136c313a896.tar.gz
upstream-90daff4cf8a86622012217d3be7ce136c313a896.tar.bz2
upstream-90daff4cf8a86622012217d3be7ce136c313a896.zip
build: image: move IMAGE_SIZE to image.mk
IMAGE_SIZE is widely used in many targets. Declare it in the default template to clean up redundant code. This also prevents deriving IMAGE_SIZE unintentionally from the previously defined device. While at it, remove duplicate KERNEL_SIZE declaration. Signed-off-by: Sungbo Eo <mans0n@gorani.run>
Diffstat (limited to 'target/linux/ar71xx/image/Makefile')
-rw-r--r--target/linux/ar71xx/image/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index 804532b55c..dea8338ddd 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -10,7 +10,7 @@ include $(INCLUDE_DIR)/image.mk
KERNEL_LOADADDR = 0x80060000
-DEVICE_VARS += BOARDNAME CMDLINE CONSOLE IMAGE_SIZE LOADER_TYPE
+DEVICE_VARS += BOARDNAME CMDLINE CONSOLE LOADER_TYPE
ifeq ($(SUBTARGET),generic)
include ./generic.mk