aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/image/Makefile
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2016-04-25 20:08:49 +0000
committerJohn Crispin <blogic@openwrt.org>2016-04-25 20:08:49 +0000
commit71c67e149c08cf388576dbf00dda10dfba216d07 (patch)
treed3ecae2cbb4aa453c52f3bc3d1a06f9551f88f30 /target/linux/ar71xx/image/Makefile
parent9098797092f663002173287fdafefbd7480aeb87 (diff)
downloadupstream-71c67e149c08cf388576dbf00dda10dfba216d07.tar.gz
upstream-71c67e149c08cf388576dbf00dda10dfba216d07.tar.bz2
upstream-71c67e149c08cf388576dbf00dda10dfba216d07.zip
ar71xx: Add TP-Link TL-WA901ND v4 support to Chaos Calmer 15.05.1
This patch backports support for the TP-Link TL-WA901ND v4 to Chaos Calmer 15.05.1, which was added into trunk recently [1]. Signed-off by Stijn Segers <francesco.borromini@inventati.org> [1]: http://patchwork.ozlabs.org/patch/606780/ git-svn-id: svn://svn.openwrt.org/openwrt/branches/chaos_calmer@49226 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar71xx/image/Makefile')
-rw-r--r--target/linux/ar71xx/image/Makefile10
1 files changed, 9 insertions, 1 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index cd77373ab3..6fb375fa21 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -688,7 +688,15 @@ define Device/tl-wa901nd-v3
DEVICE_PROFILE := TLWA901
TPLINK_HWID := 0x09010003
endef
-TARGET_DEVICES += tl-wa901nd-v3
+
+define Device/tl-wa901nd-v4
+ $(Device/tplink-4mlzma)
+ BOARDNAME := TL-WA901ND-v4
+ DEVICE_PROFILE := TLWA901
+ TPLINK_HWID := 0x09010004
+endef
+
+TARGET_DEVICES += tl-wa901nd-v3 tl-wa901nd-v4
define Device/tl-wa7210n-v2
$(Device/tplink-4mlzma)