aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/image/Makefile
diff options
context:
space:
mode:
authorStijn Tintel <stijn@linux-ipv6.be>2016-10-21 17:50:39 +0300
committerStijn Tintel <stijn@linux-ipv6.be>2016-10-27 01:50:42 +0300
commit6b0d279ca58bf6173b57c7e9b759be4552eab74a (patch)
treed7721a20792f65615a40d35f235c0316a1eab33f /target/linux/ar71xx/image/Makefile
parente19427bd7988c77e3e682d7804386702ef69b593 (diff)
downloadupstream-6b0d279ca58bf6173b57c7e9b759be4552eab74a.tar.gz
upstream-6b0d279ca58bf6173b57c7e9b759be4552eab74a.tar.bz2
upstream-6b0d279ca58bf6173b57c7e9b759be4552eab74a.zip
ar71xx: build relocate stub for generic and legacy images
Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be> Acked-by: John Crispin <john@phrozen.org>
Diffstat (limited to 'target/linux/ar71xx/image/Makefile')
-rw-r--r--target/linux/ar71xx/image/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index 56e07d82f3..26e955840a 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -79,8 +79,11 @@ define Build/loader-okli
endef
define Build/relocate-kernel
+ rm -rf $(KDIR)/relocate
+ $(CP) ../../generic/image/relocate $(KDIR)
+ $(MAKE) -C $(KDIR)/relocate KERNEL_ADDR=$(KERNEL_LOADADDR) CROSS_COMPILE=$(TARGET_CROSS)
( \
- dd if=$(KDIR)/relocate.bin bs=32 conv=sync && \
+ dd if=$(KDIR)/relocate/loader.bin bs=32 conv=sync && \
perl -e '@s = stat("$@"); print pack("N", @s[7])' && \
cat "$@" \
) > "$@.new"