aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/image/Makefile
diff options
context:
space:
mode:
authorMathias Kresin <dev@kresin.me>2016-09-11 19:05:20 +0200
committerMathias Kresin <dev@kresin.me>2016-09-13 19:36:41 +0200
commit61c2a7339a70b34cc357f9f190921365c39073f9 (patch)
tree147d330471abdc1c7908ab37608ca547bcca93f1 /target/linux/ar71xx/image/Makefile
parent14b40d61e13ce0408d5ed9dff2ad3a18ab0c2471 (diff)
downloadupstream-61c2a7339a70b34cc357f9f190921365c39073f9.tar.gz
upstream-61c2a7339a70b34cc357f9f190921365c39073f9.tar.bz2
upstream-61c2a7339a70b34cc357f9f190921365c39073f9.zip
image: remove padding parameter from append-kernel/append-rootfs
Using pad-to instead of passing the optional padding to append-kernel or append-rootfs. It could be that the value of a variable is passed. In case the variable is empty no error is thrown. Furthermore the purpose of the extra parameter is hard to get without reading the code. Signed-off-by: Mathias Kresin <dev@kresin.me>
Diffstat (limited to 'target/linux/ar71xx/image/Makefile')
-rw-r--r--target/linux/ar71xx/image/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index a8c215b36d..bce5cd3774 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -94,7 +94,7 @@ define Device/Default
KERNEL := kernel-bin | patch-cmdline | lzma | uImage lzma
COMPILE :=
IMAGES := sysupgrade.bin
- IMAGE/sysupgrade.bin = append-kernel $$$$(BLOCKSIZE) | append-rootfs | pad-rootfs | check-size $$$$(IMAGE_SIZE)
+ IMAGE/sysupgrade.bin = append-kernel | pad-to $$$$(BLOCKSIZE) | append-rootfs | pad-rootfs | check-size $$$$(IMAGE_SIZE)
endef
$(eval $(call BuildImage))