aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/image/Makefile
diff options
context:
space:
mode:
authorKoen Vandeputte <koen.vandeputte@ncentric.com>2018-10-17 17:16:51 +0200
committerKoen Vandeputte <koen.vandeputte@ncentric.com>2018-10-17 18:02:16 +0200
commit5f249333090741ecba190855b13c87fd93ca2520 (patch)
treec144e95f11cb83088b86750a5c125ec397860bf4 /target/linux/ar71xx/image/Makefile
parentdb6f9d5598a353c94578bd76dbef92dd78f3ae63 (diff)
downloadupstream-5f249333090741ecba190855b13c87fd93ca2520.tar.gz
upstream-5f249333090741ecba190855b13c87fd93ca2520.tar.bz2
upstream-5f249333090741ecba190855b13c87fd93ca2520.zip
ar71xx: Move some targets to tiny
Recent changes on ar71xx (switch to 4.14, memory compaction, ...) cause an increase in kernel size, making it too big for some devices. Move these devices to the tiny target, where kernel symbols and optimization for speed are disabled, reducing the kernel size. Devices: - EnGenius ENS202EXT - OCEDO Koala Compile-tested targets: - ar71xx->generic->default - ar71xx->smallFlash->Default Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
Diffstat (limited to 'target/linux/ar71xx/image/Makefile')
-rw-r--r--target/linux/ar71xx/image/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index c429eb39d9..804532b55c 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -15,7 +15,6 @@ DEVICE_VARS += BOARDNAME CMDLINE CONSOLE IMAGE_SIZE LOADER_TYPE
ifeq ($(SUBTARGET),generic)
include ./generic.mk
include ./generic-legacy-devices.mk
-include ./generic-senao.mk
include ./generic-tp-link.mk
include ./generic-ubnt.mk
endif
@@ -23,6 +22,7 @@ ifeq ($(SUBTARGET),tiny)
include ./tiny.mk
include ./tiny-tp-link.mk
include ./tiny-legacy-devices.mk
+include ./tiny-senao.mk
endif
ifeq ($(SUBTARGET),nand)
include ./nand.mk