aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/image/Makefile
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2016-04-09 10:26:46 +0000
committerJohn Crispin <john@openwrt.org>2016-04-09 10:26:46 +0000
commit5f1a82ec4ffebc668a739d2a2fb72da8dbbeaaa5 (patch)
treea8d8d3656fc242a86861e56af0d92d64e77f1ab0 /target/linux/ar71xx/image/Makefile
parentd9799dea89ea1da5bbc0c9146a2e1ae5e54bd742 (diff)
downloadupstream-5f1a82ec4ffebc668a739d2a2fb72da8dbbeaaa5.tar.gz
upstream-5f1a82ec4ffebc668a739d2a2fb72da8dbbeaaa5.tar.bz2
upstream-5f1a82ec4ffebc668a739d2a2fb72da8dbbeaaa5.zip
ar71xx: add TP-Link TL-WA901ND-v4 support
Signed-off-by: Tiziano Bacocco <tizbac2@gmail.com> SVN-Revision: 49158
Diffstat (limited to 'target/linux/ar71xx/image/Makefile')
-rw-r--r--target/linux/ar71xx/image/Makefile10
1 files changed, 9 insertions, 1 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index cacdd50bac..e4e2fcf441 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -1087,7 +1087,15 @@ define Device/tl-wa901nd-v3
DEVICE_PROFILE := TLWA901
TPLINK_HWID := 0x09010003
endef
-TARGET_DEVICES += tl-wa901nd-v1 tl-wa901nd-v2 tl-wa901nd-v3
+
+define Device/tl-wa901nd-v4
+ $(Device/tplink-4mlzma)
+ BOARDNAME := TL-WA901ND-v4
+ DEVICE_PROFILE := TLWA901
+ TPLINK_HWID := 0x09010004
+endef
+
+TARGET_DEVICES += tl-wa901nd-v1 tl-wa901nd-v2 tl-wa901nd-v3 tl-wa901nd-v4
define Device/tl-wa7210n-v2
$(Device/tplink-4mlzma)