aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/image/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2016-11-08 11:50:50 +0100
committerFelix Fietkau <nbd@nbd.name>2016-11-08 11:51:27 +0100
commit462a7c0e96d70ba82dfb5ddd41c82b66c3261ca2 (patch)
treeac155ecebb05cd1d50d3946141275d0163f340e4 /target/linux/ar71xx/image/Makefile
parent28955d9707345d9a684ec81c711c6914c2135c42 (diff)
downloadupstream-462a7c0e96d70ba82dfb5ddd41c82b66c3261ca2.tar.gz
upstream-462a7c0e96d70ba82dfb5ddd41c82b66c3261ca2.tar.bz2
upstream-462a7c0e96d70ba82dfb5ddd41c82b66c3261ca2.zip
ar71xx: fix kernel relocate stub parallel build issue
Use per-kernel directory Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'target/linux/ar71xx/image/Makefile')
-rw-r--r--target/linux/ar71xx/image/Makefile9
1 files changed, 5 insertions, 4 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index 26e955840a..64221a3d6c 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -79,15 +79,16 @@ define Build/loader-okli
endef
define Build/relocate-kernel
- rm -rf $(KDIR)/relocate
- $(CP) ../../generic/image/relocate $(KDIR)
- $(MAKE) -C $(KDIR)/relocate KERNEL_ADDR=$(KERNEL_LOADADDR) CROSS_COMPILE=$(TARGET_CROSS)
+ rm -rf $@.relocate
+ $(CP) ../../generic/image/relocate $@.relocate
+ $(MAKE) -j1 -C $@.relocate KERNEL_ADDR=$(KERNEL_LOADADDR) CROSS_COMPILE=$(TARGET_CROSS)
( \
- dd if=$(KDIR)/relocate/loader.bin bs=32 conv=sync && \
+ dd if=$@.relocate/loader.bin bs=32 conv=sync && \
perl -e '@s = stat("$@"); print pack("N", @s[7])' && \
cat "$@" \
) > "$@.new"
mv "$@.new" "$@"
+ rm -rf $@.relocate
endef
define Build/copy-file