aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/generic
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2012-01-28 13:19:49 +0000
committerFlorian Fainelli <florian@openwrt.org>2012-01-28 13:19:49 +0000
commitc003d83f1ae5887b0e50ea7a2945f20044df1503 (patch)
tree181ca4d51fe3691d97e3ca54996020c8ba7ce03c /target/linux/ar71xx/generic
parent906dfaac140f3a0de973c304808a5be042f52b5d (diff)
downloadupstream-c003d83f1ae5887b0e50ea7a2945f20044df1503.tar.gz
upstream-c003d83f1ae5887b0e50ea7a2945f20044df1503.tar.bz2
upstream-c003d83f1ae5887b0e50ea7a2945f20044df1503.zip
[ar71xx] add support for the Atheros AP113 reference board
This reference board is equipped with: - AR7242 SoC - AR9580 on-board Wi-Fi - AR8316 switch git-svn-id: svn://svn.openwrt.org/openwrt/trunk@29935 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar71xx/generic')
-rw-r--r--target/linux/ar71xx/generic/profiles/atheros.mk11
1 files changed, 11 insertions, 0 deletions
diff --git a/target/linux/ar71xx/generic/profiles/atheros.mk b/target/linux/ar71xx/generic/profiles/atheros.mk
index f26d7a788a..4ce4cd5129 100644
--- a/target/linux/ar71xx/generic/profiles/atheros.mk
+++ b/target/linux/ar71xx/generic/profiles/atheros.mk
@@ -5,6 +5,17 @@
# See /LICENSE for more information.
#
+define Profile/AP113
+ NAME:=Atheros AP113 reference board
+ PACKAGES:=kmod-usb-core kmod-usb2
+endef
+
+define Profile/AP113/description
+ Package set optimized for the Atheros AP113 reference board.
+endef
+
+$(eval $(call Profile,AP113))
+
define Profile/AP121
NAME:=Atheros AP121 reference board
PACKAGES:=kmod-usb-core kmod-usb2