aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/generic/profiles/openmesh.mk
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2012-12-18 15:16:05 +0000
committerGabor Juhos <juhosg@openwrt.org>2012-12-18 15:16:05 +0000
commit149534f3ed7395a796ca5aab7593109d54ae8f87 (patch)
treef7fee4636dc121bb90f8d09aced6807d6e08f142 /target/linux/ar71xx/generic/profiles/openmesh.mk
parent8903f8581b25e9ba7eb7ce2e7a246f9dc59fbc64 (diff)
downloadupstream-149534f3ed7395a796ca5aab7593109d54ae8f87.tar.gz
upstream-149534f3ed7395a796ca5aab7593109d54ae8f87.tar.bz2
upstream-149534f3ed7395a796ca5aab7593109d54ae8f87.zip
ar71xx: image: add OpenMesh profile
It allows to build firmware images for all OpenMesh products in one step. Signed-off-by: Gabor Juhos <juhosg@openwrt.org> SVN-Revision: 34761
Diffstat (limited to 'target/linux/ar71xx/generic/profiles/openmesh.mk')
-rw-r--r--target/linux/ar71xx/generic/profiles/openmesh.mk13
1 files changed, 12 insertions, 1 deletions
diff --git a/target/linux/ar71xx/generic/profiles/openmesh.mk b/target/linux/ar71xx/generic/profiles/openmesh.mk
index 92aec4b79c..53ae5987f9 100644
--- a/target/linux/ar71xx/generic/profiles/openmesh.mk
+++ b/target/linux/ar71xx/generic/profiles/openmesh.mk
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2011 OpenWrt.org
+# Copyright (C) 2011-2012 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -27,3 +27,14 @@ endef
$(eval $(call Profile,MR600))
+define Profile/OPENMESH
+ NAME:=OpenMesh products
+ PACKAGES:=kmod-ath9k om-watchdog
+endef
+
+define Profile/OPENMESH/Description
+ Build images for all OpenMesh products.
+endef
+
+$(eval $(call Profile,OPENMESH))
+