aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/files
diff options
context:
space:
mode:
authorPiotr Dymacz <pepe2k@gmail.com>2018-01-05 11:35:45 +0100
committerPiotr Dymacz <pepe2k@gmail.com>2018-01-14 21:30:16 +0100
commit4b0eebe9dfa49f995474322f2c6998026534a5f8 (patch)
tree22e8ca9428a42da7aa590188145c3d408f749fc4 /target/linux/ar71xx/files
parent62610129b23db2ff995191940b88a6e56d0a87d6 (diff)
downloadupstream-4b0eebe9dfa49f995474322f2c6998026534a5f8.tar.gz
upstream-4b0eebe9dfa49f995474322f2c6998026534a5f8.tar.bz2
upstream-4b0eebe9dfa49f995474322f2c6998026534a5f8.zip
ar71xx: add support for ALFA Network N5Q
ALFA Network N5Q is a successor of previous model, the N5 (outdoor CPE/AP, based on Atheros AR7240 + AR9280). New version is based on Atheros AR9344. Specification: - 550/400/200 MHz (CPU/DDR/AHB) - 64 MB of RAM (DDR2) - 16 MB of FLASH (SPI NOR) - 2x 10/100 Mbps Ethernet, with passive PoE support (24 V) - 2T2R 5 GHz (AR9344), with ext. PA (RFPA5542) and LNA, up to 27 dBm - 8x LED (7 are driven by GPIO) - 1x button (reset) - external h/w watchdog (EM6324QYSP5B, disabled and not used) - header for optional 802.3at/af PoE module - DC jack for main power input (optional, not installed by default) - UART header on PCB Flash instruction: You can use sysupgrade image directly in vendor firmare which is based on OpenWrt/LEDE. Alternatively, you can use web recovery mode in U-Boot: 1. Configure PC with static IP 192.168.1.2/24. 2. Connect PC with one of RJ45 ports, press the reset button, power up device, wait for first blink of all LEDs (indicates network setup), then keep button for 3 following blinks and release it. 3. Open 192.168.1.1 address in your browser and upload sysupgrade image. Signed-off-by: Piotr Dymacz <pepe2k@gmail.com>
Diffstat (limited to 'target/linux/ar71xx/files')
-rw-r--r--target/linux/ar71xx/files/arch/mips/ath79/Kconfig.openwrt8
-rw-r--r--target/linux/ar71xx/files/arch/mips/ath79/Makefile1
-rw-r--r--target/linux/ar71xx/files/arch/mips/ath79/mach-n5q.c132
-rw-r--r--target/linux/ar71xx/files/arch/mips/ath79/machtypes.h1
4 files changed, 142 insertions, 0 deletions
diff --git a/target/linux/ar71xx/files/arch/mips/ath79/Kconfig.openwrt b/target/linux/ar71xx/files/arch/mips/ath79/Kconfig.openwrt
index f2717e86e9..43096463c2 100644
--- a/target/linux/ar71xx/files/arch/mips/ath79/Kconfig.openwrt
+++ b/target/linux/ar71xx/files/arch/mips/ath79/Kconfig.openwrt
@@ -2008,6 +2008,14 @@ config ATH79_MACH_ZCN_1523H
select ATH79_DEV_LEDS_GPIO
select ATH79_DEV_M25P80
+config ATH79_MACH_N5Q
+ bool "ALFA Network N5Q support"
+ select SOC_AR934X
+ select ATH79_DEV_ETH
+ select ATH79_DEV_GPIO_BUTTONS
+ select ATH79_DEV_LEDS_GPIO
+ select ATH79_DEV_WMAC
+
config ATH79_MACH_NBG460N
bool "Zyxel NBG460N/550N/550NH board support"
select SOC_AR913X
diff --git a/target/linux/ar71xx/files/arch/mips/ath79/Makefile b/target/linux/ar71xx/files/arch/mips/ath79/Makefile
index 0e581005d7..53edaac712 100644
--- a/target/linux/ar71xx/files/arch/mips/ath79/Makefile
+++ b/target/linux/ar71xx/files/arch/mips/ath79/Makefile
@@ -147,6 +147,7 @@ obj-$(CONFIG_ATH79_MACH_MYNET_N750) += mach-mynet-n750.o
obj-$(CONFIG_ATH79_MACH_MYNET_REXT) += mach-mynet-rext.o
obj-$(CONFIG_ATH79_MACH_MZK_W04NU) += mach-mzk-w04nu.o
obj-$(CONFIG_ATH79_MACH_MZK_W300NH) += mach-mzk-w300nh.o
+obj-$(CONFIG_ATH79_MACH_N5Q) += mach-n5q.o
obj-$(CONFIG_ATH79_MACH_NBG460N) += mach-nbg460n.o
obj-$(CONFIG_ATH79_MACH_NBG6716) += mach-nbg6716.o
obj-$(CONFIG_ATH79_MACH_RAMBUTAN) += mach-rambutan.o
diff --git a/target/linux/ar71xx/files/arch/mips/ath79/mach-n5q.c b/target/linux/ar71xx/files/arch/mips/ath79/mach-n5q.c
new file mode 100644
index 0000000000..895fc32933
--- /dev/null
+++ b/target/linux/ar71xx/files/arch/mips/ath79/mach-n5q.c
@@ -0,0 +1,132 @@
+/*
+ * ALFA Network N5Q board support
+ *
+ * Copyright (C) 2018 Piotr Dymacz <pepe2k@gmail.com>
+ *
+ * This program is free software; you can redistribute it and/or modify it
+ * under the terms of the GNU General Public License version 2 as published
+ * by the Free Software Foundation.
+ */
+
+#include <linux/gpio.h>
+#include <linux/platform_device.h>
+
+#include <asm/mach-ath79/ath79.h>
+#include <asm/mach-ath79/ar71xx_regs.h>
+
+#include "common.h"
+#include "dev-eth.h"
+#include "dev-gpio-buttons.h"
+#include "dev-leds-gpio.h"
+#include "dev-m25p80.h"
+#include "dev-wmac.h"
+#include "machtypes.h"
+
+#define N5Q_GPIO_LED_LAN 19
+#define N5Q_GPIO_LED_SIGNAL1 0
+#define N5Q_GPIO_LED_SIGNAL2 1
+#define N5Q_GPIO_LED_SIGNAL3 2
+#define N5Q_GPIO_LED_SIGNAL4 3
+#define N5Q_GPIO_LED_WAN 18
+#define N5Q_GPIO_LED_WLAN 12
+
+#define N5Q_GPIO_WDT_EN 16
+#define N5Q_GPIO_WDT_IN 17
+
+#define N5Q_GPIO_BTN_RESET 11
+
+#define N5Q_MAC0_OFFSET 0
+#define N5Q_MAC1_OFFSET 6
+#define N5Q_WMAC_CALDATA_OFFSET 0x1000
+
+#define N5Q_KEYS_POLL_INTERVAL 20
+#define N5Q_KEYS_DEBOUNCE_INTERVAL (3 * N5Q_KEYS_POLL_INTERVAL)
+
+static struct gpio_led n5q_leds_gpio[] __initdata = {
+ {
+ .name = "n5q:green:lan",
+ .gpio = N5Q_GPIO_LED_LAN,
+ .active_low = 1,
+ }, {
+ .name = "n5q:red:signal1",
+ .gpio = N5Q_GPIO_LED_SIGNAL1,
+ .active_low = 1,
+ }, {
+ .name = "n5q:orange:signal2",
+ .gpio = N5Q_GPIO_LED_SIGNAL2,
+ .active_low = 1,
+ }, {
+ .name = "n5q:green:signal3",
+ .gpio = N5Q_GPIO_LED_SIGNAL3,
+ .active_low = 1,
+ }, {
+ .name = "n5q:green:signal4",
+ .gpio = N5Q_GPIO_LED_SIGNAL4,
+ .active_low = 1,
+ }, {
+ .name = "n5q:green:wan",
+ .gpio = N5Q_GPIO_LED_WAN,
+ .active_low = 1,
+ }, {
+ .name = "n5q:green:wlan",
+ .gpio = N5Q_GPIO_LED_WLAN,
+ .active_low = 1,
+ },
+};
+
+static struct gpio_keys_button n5q_gpio_keys[] __initdata = {
+ {
+ .desc = "reset",
+ .type = EV_KEY,
+ .code = KEY_RESTART,
+ .debounce_interval = N5Q_KEYS_DEBOUNCE_INTERVAL,
+ .gpio = N5Q_GPIO_BTN_RESET,
+ .active_low = 1,
+ },
+};
+
+static void __init n5q_setup(void)
+{
+ u8 *art = (u8 *) KSEG1ADDR(0x1f070000);
+
+ ath79_register_m25p80(NULL);
+
+ ath79_register_mdio(1, 0x0);
+
+ ath79_switch_data.phy4_mii_en = 1;
+ ath79_switch_data.phy_poll_mask = 0xf7;
+
+ /* LAN */
+ ath79_eth1_data.duplex = DUPLEX_FULL;
+ ath79_eth1_data.phy_if_mode = PHY_INTERFACE_MODE_GMII;
+ ath79_init_mac(ath79_eth1_data.mac_addr, art + N5Q_MAC1_OFFSET, 0);
+ ath79_register_eth(1);
+
+ /* WAN */
+ ath79_eth0_data.duplex = DUPLEX_FULL;
+ ath79_eth0_data.mii_bus_dev = &ath79_mdio1_device.dev;
+ ath79_eth0_data.phy_if_mode = PHY_INTERFACE_MODE_MII;
+ ath79_eth0_data.phy_mask = BIT(4);
+ ath79_eth0_data.speed = SPEED_100;
+ ath79_init_mac(ath79_eth0_data.mac_addr, art + N5Q_MAC0_OFFSET, 0);
+ ath79_register_eth(0);
+
+ ath79_register_leds_gpio(-1, ARRAY_SIZE(n5q_leds_gpio),
+ n5q_leds_gpio);
+
+ ath79_register_gpio_keys_polled(-1, N5Q_KEYS_POLL_INTERVAL,
+ ARRAY_SIZE(n5q_gpio_keys),
+ n5q_gpio_keys);
+
+ gpio_request_one(N5Q_GPIO_WDT_IN,
+ GPIOF_OUT_INIT_LOW | GPIOF_EXPORT_DIR_FIXED,
+ "WDT input");
+
+ gpio_request_one(N5Q_GPIO_WDT_EN,
+ GPIOF_OUT_INIT_LOW | GPIOF_EXPORT_DIR_FIXED,
+ "WDT enable");
+
+ ath79_register_wmac(art + N5Q_WMAC_CALDATA_OFFSET, NULL);
+}
+
+MIPS_MACHINE(ATH79_MACH_N5Q, "N5Q", "ALFA Network N5Q", n5q_setup);
diff --git a/target/linux/ar71xx/files/arch/mips/ath79/machtypes.h b/target/linux/ar71xx/files/arch/mips/ath79/machtypes.h
index c2cb8b6126..06fa4768c1 100644
--- a/target/linux/ar71xx/files/arch/mips/ath79/machtypes.h
+++ b/target/linux/ar71xx/files/arch/mips/ath79/machtypes.h
@@ -143,6 +143,7 @@ enum ath79_mach_type {
ATH79_MACH_MYNET_REXT, /* WD My Net Wi-Fi Range Extender */
ATH79_MACH_MZK_W04NU, /* Planex MZK-W04NU */
ATH79_MACH_MZK_W300NH, /* Planex MZK-W300NH */
+ ATH79_MACH_N5Q, /* ALFA Network N5Q */
ATH79_MACH_NBG460N, /* Zyxel NBG460N/550N/550NH */
ATH79_MACH_NBG6616, /* Zyxel NBG6616 */
ATH79_MACH_NBG6716, /* Zyxel NBG6716 */