aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/files/arch/mips/ath79/Makefile
diff options
context:
space:
mode:
authorChris Blake <chrisrblake93@gmail.com>2017-04-26 22:09:27 -0500
committerPiotr Dymacz <pepe2k@gmail.com>2017-05-15 22:58:59 +0200
commit10d11859dfbad0b4482d1a50b20ef91eeeeca2d7 (patch)
treeb51f9723c883450d618e8b9536365cfb94c596b2 /target/linux/ar71xx/files/arch/mips/ath79/Makefile
parentcd9d0f9e97c912d45bbceb7868bcec51653de299 (diff)
downloadupstream-10d11859dfbad0b4482d1a50b20ef91eeeeca2d7.tar.gz
upstream-10d11859dfbad0b4482d1a50b20ef91eeeeca2d7.tar.bz2
upstream-10d11859dfbad0b4482d1a50b20ef91eeeeca2d7.zip
ar71xx: add support for Aerohive AP-121
This adds support for Aerohive AP-121 access point. Specification: - SoC: Atheros AR9344-BC2A at 560MHz - WiFi 1: 2.4GHz Atheros AR9340? - SoC - WiFi 2: 5.0GHz Atheros AR9382-AL1A - Memory: 128MB from 2x Nanya NT5TU32M16DG-AC - SPI: 1MB Macronix MX25L8006E - NAND: 128MB Hynix H27U1G8F2BTR-BC - Ethernet: Atheros AR8035-A - USB: 1x 2.0 - TPM: Atmel SC3204 Flashing: 1. Hook into UART (9600 baud) and enter U-Boot. You may need to enter a password of administrator or AhNf?d@ta06 if prompted. 2. Once in U-Boot, download and flash LEDE factory image over tftp: dhcp; setenv serverip tftp-server-ip; tftpboot 0x81000000 lede-ar71xx-nand-hiveap-121-squashfs-factory.bin; nand erase 0x800000 0x800000; nand write 0x81000000 0x800000 0x800000; reset; Signed-off-by: Chris Blake <chrisrblake93@gmail.com> [minor text changes in commit subject and description, fixed alphabetical order in etc/diag.sh, use only model name in lib/ar71xx.sh, fixed code style issues in mach-hiveap-121.c, ubinized factory image] Signed-off-by: Piotr Dymacz <pepe2k@gmail.com>
Diffstat (limited to 'target/linux/ar71xx/files/arch/mips/ath79/Makefile')
-rw-r--r--target/linux/ar71xx/files/arch/mips/ath79/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/target/linux/ar71xx/files/arch/mips/ath79/Makefile b/target/linux/ar71xx/files/arch/mips/ath79/Makefile
index f503002288..2868adcaef 100644
--- a/target/linux/ar71xx/files/arch/mips/ath79/Makefile
+++ b/target/linux/ar71xx/files/arch/mips/ath79/Makefile
@@ -117,6 +117,7 @@ obj-$(CONFIG_ATH79_MACH_GL_INET) += mach-gl-inet.o
obj-$(CONFIG_ATH79_MACH_GL_MIFI) += mach-gl-mifi.o
obj-$(CONFIG_ATH79_MACH_GS_MINIBOX_V1) += mach-gs-minibox-v1.o
obj-$(CONFIG_ATH79_MACH_GS_OOLITE) += mach-gs-oolite.o
+obj-$(CONFIG_ATH79_MACH_HIVEAP_121) += mach-hiveap-121.o
obj-$(CONFIG_ATH79_MACH_HIWIFI_HC6361) += mach-hiwifi-hc6361.o
obj-$(CONFIG_ATH79_MACH_HORNET_UB) += mach-hornet-ub.o
obj-$(CONFIG_ATH79_MACH_JA76PF) += mach-ja76pf.o