aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/files-2.6.39/arch/mips
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2012-01-28 13:19:49 +0000
committerFlorian Fainelli <florian@openwrt.org>2012-01-28 13:19:49 +0000
commiteeb00634a7715204481a5fd83664a697e414bbfd (patch)
treee2b59dde0c8fa62d0d1c6736bd1d593572afcd42 /target/linux/ar71xx/files-2.6.39/arch/mips
parent405a0f390567dc8be1b3ad598f76d77e332bdfa3 (diff)
downloadupstream-eeb00634a7715204481a5fd83664a697e414bbfd.tar.gz
upstream-eeb00634a7715204481a5fd83664a697e414bbfd.tar.bz2
upstream-eeb00634a7715204481a5fd83664a697e414bbfd.zip
add support for the Atheros AP113 reference board
This reference board is equipped with: - AR7242 SoC - AR9580 on-board Wi-Fi - AR8316 switch SVN-Revision: 29935
Diffstat (limited to 'target/linux/ar71xx/files-2.6.39/arch/mips')
-rw-r--r--target/linux/ar71xx/files-2.6.39/arch/mips/ar71xx/Kconfig9
-rw-r--r--target/linux/ar71xx/files-2.6.39/arch/mips/ar71xx/Makefile1
-rw-r--r--target/linux/ar71xx/files-2.6.39/arch/mips/ar71xx/mach-ap113.c129
-rw-r--r--target/linux/ar71xx/files-2.6.39/arch/mips/ar71xx/machtype.h1
4 files changed, 140 insertions, 0 deletions
diff --git a/target/linux/ar71xx/files-2.6.39/arch/mips/ar71xx/Kconfig b/target/linux/ar71xx/files-2.6.39/arch/mips/ar71xx/Kconfig
index 5abe999b2d..cf1664e76e 100644
--- a/target/linux/ar71xx/files-2.6.39/arch/mips/ar71xx/Kconfig
+++ b/target/linux/ar71xx/files-2.6.39/arch/mips/ar71xx/Kconfig
@@ -59,6 +59,15 @@ config AR71XX_MACH_AP96
select AR71XX_DEV_LEDS_GPIO
select AR71XX_DEV_USB
+config AR71XX_MACH_AP113
+ bool "Atheros AP113 board support"
+ select SOC_AR724X
+ select AR71XX_DEV_M25P80
+ select AR71XX_DEV_PB9X_PCI if PCI
+ select AR71XX_DEV_GPIO_BUTTONS
+ select AR71XX_DEV_LEDS_GPIO
+ select AR71XX_DEV_USB
+
config AR71XX_MACH_AP121
bool "Atheros AP121 board support"
select AR71XX_DEV_M25P80
diff --git a/target/linux/ar71xx/files-2.6.39/arch/mips/ar71xx/Makefile b/target/linux/ar71xx/files-2.6.39/arch/mips/ar71xx/Makefile
index efd8bd2772..9b36bcfbba 100644
--- a/target/linux/ar71xx/files-2.6.39/arch/mips/ar71xx/Makefile
+++ b/target/linux/ar71xx/files-2.6.39/arch/mips/ar71xx/Makefile
@@ -31,6 +31,7 @@ obj-$(CONFIG_AR71XX_PCI_ATH9K_FIXUP) += pci-ath9k-fixup.o
obj-$(CONFIG_AR71XX_MACH_ALFA_AP96) += mach-alfa-ap96.o
obj-$(CONFIG_AR71XX_MACH_ALFA_NX) += mach-alfa-nx.o
obj-$(CONFIG_AR71XX_MACH_ALL0258N) += mach-all0258n.o
+obj-$(CONFIG_AR71XX_MACH_AP113) += mach-ap113.o
obj-$(CONFIG_AR71XX_MACH_AP121) += mach-ap121.o
obj-$(CONFIG_AR71XX_MACH_AP81) += mach-ap81.o
obj-$(CONFIG_AR71XX_MACH_AP83) += mach-ap83.o
diff --git a/target/linux/ar71xx/files-2.6.39/arch/mips/ar71xx/mach-ap113.c b/target/linux/ar71xx/files-2.6.39/arch/mips/ar71xx/mach-ap113.c
new file mode 100644
index 0000000000..2ece3987b2
--- /dev/null
+++ b/target/linux/ar71xx/files-2.6.39/arch/mips/ar71xx/mach-ap113.c
@@ -0,0 +1,129 @@
+/*
+ * Atheros AP113 board support
+ *
+ * Copyright (C) 2011 Florian Fainelli <florian@openwrt.org>
+ *
+ * This program is free software; you can redistribute it and/or modify it
+ * under the terms of the GNU General Public License version 2 as published
+ * by the Free Software Foundation.
+ */
+
+#include <linux/mtd/mtd.h>
+#include <linux/mtd/partitions.h>
+#include <linux/spi/flash.h>
+
+#include "machtype.h"
+#include "devices.h"
+#include "dev-gpio-buttons.h"
+#include "dev-leds-gpio.h"
+#include "dev-m25p80.h"
+#include "dev-pb9x-pci.h"
+#include "dev-usb.h"
+
+#define AP113_GPIO_LED_USB 0
+#define AP113_GPIO_LED_STATUS 1
+#define AP113_GPIO_LED_ST 11
+
+#define AP113_GPIO_BTN_JUMPSTART 12
+
+#define AP113_KEYS_POLL_INTERVAL 20 /* msecs */
+#define AP113_KEYS_DEBOUNCE_INTERVAL (3 * AP113_KEYS_POLL_INTERVAL)
+
+#ifdef CONFIG_MTD_PARTITIONS
+static struct mtd_partition ap113_parts[] = {
+ {
+ .name = "u-boot",
+ .offset = 0,
+ .size = 0x010000,
+ .mask_flags = MTD_WRITEABLE,
+ },
+ {
+ .name = "rootfs",
+ .offset = 0x010000,
+ .size = 0x300000,
+ },
+ {
+ .name = "uImage",
+ .offset = 0x300000,
+ .size = 0x3e0000,
+ },
+ {
+ .name = "NVRAM",
+ .offset = 0x3e0000,
+ .size = 0x010000,
+ },
+ {
+ .name = "ART",
+ .offset = 0x3f0000,
+ .size = 0x010000,
+ .mask_flags = MTD_WRITEABLE,
+ },
+};
+#define ap113_nr_parts ARRAY_SIZE(ap113_parts)
+#else
+#define ap113_parts NULL
+#define ap113_nr_parts 0
+#endif /* CONFIG_MTD_PARTITIONS */
+
+static struct flash_platform_data ap113_flash_data = {
+ .parts = ap113_parts,
+ .nr_parts = ap113_nr_parts,
+};
+
+static struct gpio_led ap113_leds_gpio[] __initdata = {
+ {
+ .name = "ap113:green:usb",
+ .gpio = AP113_GPIO_LED_USB,
+ .active_low = 1,
+ },
+ {
+ .name = "ap113:green:status",
+ .gpio = AP113_GPIO_LED_STATUS,
+ .active_low = 1,
+ },
+ {
+ .name = "ap113:green:st",
+ .gpio = AP113_GPIO_LED_ST,
+ .active_low = 1,
+ }
+};
+
+static struct gpio_keys_button ap113_gpio_keys[] __initdata = {
+ {
+ .desc = "jumpstart button",
+ .type = EV_KEY,
+ .code = KEY_WPS_BUTTON,
+ .debounce_interval = AP113_KEYS_DEBOUNCE_INTERVAL,
+ .gpio = AP113_GPIO_BTN_JUMPSTART,
+ .active_low = 1,
+ },
+};
+
+static void __init ap113_setup(void)
+{
+ u8 *mac = (u8 *) KSEG1ADDR(0x1fff0000);
+
+ ar71xx_add_device_m25p80(&ap113_flash_data);
+
+ ar71xx_add_device_mdio(0, ~BIT(0));
+ ar71xx_init_mac(ar71xx_eth0_data.mac_addr, mac, 0);
+ ar71xx_eth0_data.phy_if_mode = PHY_INTERFACE_MODE_RGMII;
+ ar71xx_eth0_data.speed = SPEED_1000;
+ ar71xx_eth0_data.duplex = DUPLEX_FULL;
+ ar71xx_eth0_data.phy_mask = BIT(0);
+
+ ar71xx_add_device_eth(0);
+
+ ar71xx_register_gpio_keys_polled(-1, AP113_KEYS_POLL_INTERVAL,
+ ARRAY_SIZE(ap113_gpio_keys),
+ ap113_gpio_keys);
+ ar71xx_add_device_leds_gpio(-1, ARRAY_SIZE(ap113_leds_gpio),
+ ap113_leds_gpio);
+
+ ar71xx_add_device_usb();
+
+ pb9x_pci_init();
+}
+
+MIPS_MACHINE(AR71XX_MACH_AP113, "AP113", "Atheros AP113",
+ ap113_setup);
diff --git a/target/linux/ar71xx/files-2.6.39/arch/mips/ar71xx/machtype.h b/target/linux/ar71xx/files-2.6.39/arch/mips/ar71xx/machtype.h
index 83038c64ce..1be8dbbf34 100644
--- a/target/linux/ar71xx/files-2.6.39/arch/mips/ar71xx/machtype.h
+++ b/target/linux/ar71xx/files-2.6.39/arch/mips/ar71xx/machtype.h
@@ -19,6 +19,7 @@ enum ar71xx_mach_type {
AR71XX_MACH_ALFA_AP96, /* ALFA Network AP96 board */
AR71XX_MACH_ALFA_NX, /* ALFA Network N2/N5 board */
AR71XX_MACH_ALL0258N, /* Allnet ALL0258N */
+ AR71XX_MACH_AP113, /* Atheros AP113 */
AR71XX_MACH_AP121, /* Atheros AP121 */
AR71XX_MACH_AP121_MINI, /* Atheros AP121-MINI */
AR71XX_MACH_AP81, /* Atheros AP81 */