aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar7/patches-4.14/320-ac49x-mtd-partitions.patch
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2019-05-11 13:47:37 +0200
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-01-08 16:45:08 +0100
commit90740f52e9b9076d60119cfe4669366588131fe6 (patch)
treef895bbb35c1a71b9488c4679a5d5f8694082b223 /target/linux/ar7/patches-4.14/320-ac49x-mtd-partitions.patch
parent08ec23f8ea9c63384e127f934bfb8086b8ab368a (diff)
downloadupstream-90740f52e9b9076d60119cfe4669366588131fe6.tar.gz
upstream-90740f52e9b9076d60119cfe4669366588131fe6.tar.bz2
upstream-90740f52e9b9076d60119cfe4669366588131fe6.zip
ar7: update kernel to version 4.14
This adds support for kernel 4.14 to the target and directly make it the default kernel version to use. This patch is build-tested only, but has never been device-tested. It is only added to preserve the changes in Git history prior to removing this target. Use it with care. Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de> [rebased and extended commit message, refreshed patches for 4.14.162] Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target/linux/ar7/patches-4.14/320-ac49x-mtd-partitions.patch')
-rw-r--r--target/linux/ar7/patches-4.14/320-ac49x-mtd-partitions.patch35
1 files changed, 35 insertions, 0 deletions
diff --git a/target/linux/ar7/patches-4.14/320-ac49x-mtd-partitions.patch b/target/linux/ar7/patches-4.14/320-ac49x-mtd-partitions.patch
new file mode 100644
index 0000000000..7ae49b07e8
--- /dev/null
+++ b/target/linux/ar7/patches-4.14/320-ac49x-mtd-partitions.patch
@@ -0,0 +1,35 @@
+--- a/drivers/mtd/Kconfig
++++ b/drivers/mtd/Kconfig
+@@ -154,6 +154,11 @@ config MTD_OF_PARTS
+ the partition map from the children of the flash node,
+ as described in Documentation/devicetree/bindings/mtd/partition.txt.
+
++config MTD_AC49X_PARTS
++ tristate "AudioCodes AC49X partitioning support"
++ ---help---
++ AudioCodes AC49X partitioning support
++
+ config MTD_AR7_PARTS
+ tristate "TI AR7 partitioning support"
+ ---help---
+--- a/drivers/mtd/Makefile
++++ b/drivers/mtd/Makefile
+@@ -12,6 +12,7 @@ obj-$(CONFIG_MTD_SPLIT) += mtdsplit/
+ obj-$(CONFIG_MTD_OF_PARTS) += ofpart.o
+ obj-$(CONFIG_MTD_REDBOOT_PARTS) += redboot.o
+ obj-$(CONFIG_MTD_CMDLINE_PARTS) += cmdlinepart.o
++obj-$(CONFIG_MTD_AC49X_PARTS) += ac49xpart.o
+ obj-$(CONFIG_MTD_AFS_PARTS) += afs.o
+ obj-$(CONFIG_MTD_AR7_PARTS) += ar7part.o titanpart.o
+ obj-$(CONFIG_MTD_BCM63XX_PARTS) += bcm63xxpart.o
+--- a/arch/mips/ar7/platform.c
++++ b/arch/mips/ar7/platform.c
+@@ -200,7 +200,7 @@ static struct resource physmap_flash_res
+ .end = 0x11ffffff,
+ };
+
+-static const char *ar7_probe_types[] = { "ar7part", NULL };
++static const char *ar7_probe_types[] = { "ac49xpart", "ar7part", NULL };
+
+ static struct physmap_flash_data physmap_flash_data = {
+ .width = 2,