aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar7/patches-3.3/110-flash.patch
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2012-11-27 18:42:49 +0000
committerFlorian Fainelli <florian@openwrt.org>2012-11-27 18:42:49 +0000
commitee16e144bb2ece81273f1e2712ba60e1e59d1563 (patch)
treeab457a8792e8a3de518cee2ef99e90ef258df8d0 /target/linux/ar7/patches-3.3/110-flash.patch
parent7196f5d7c8ec0de8ae06cf664adbf8cdda2c594d (diff)
downloadupstream-ee16e144bb2ece81273f1e2712ba60e1e59d1563.tar.gz
upstream-ee16e144bb2ece81273f1e2712ba60e1e59d1563.tar.bz2
upstream-ee16e144bb2ece81273f1e2712ba60e1e59d1563.zip
use physmap-flash part_probe_types
Signed-off-by: Florian Fainelli <florian@openwrt.org> SVN-Revision: 34398
Diffstat (limited to 'target/linux/ar7/patches-3.3/110-flash.patch')
-rw-r--r--target/linux/ar7/patches-3.3/110-flash.patch20
1 files changed, 8 insertions, 12 deletions
diff --git a/target/linux/ar7/patches-3.3/110-flash.patch b/target/linux/ar7/patches-3.3/110-flash.patch
index 80229c104f..e42436875b 100644
--- a/target/linux/ar7/patches-3.3/110-flash.patch
+++ b/target/linux/ar7/patches-3.3/110-flash.patch
@@ -1,14 +1,3 @@
---- a/drivers/mtd/maps/physmap.c
-+++ b/drivers/mtd/maps/physmap.c
-@@ -78,7 +78,7 @@ static const char *rom_probe_types[] = {
- "map_rom",
- NULL };
- static const char *part_probe_types[] = { "cmdlinepart", "RedBoot", "afs",
-- NULL };
-+ "ar7part", NULL };
-
- static int physmap_flash_probe(struct platform_device *dev)
- {
--- a/drivers/mtd/Makefile
+++ b/drivers/mtd/Makefile
@@ -10,7 +10,7 @@ obj-$(CONFIG_MTD_OF_PARTS) += ofpart.o
@@ -22,7 +11,7 @@
--- a/arch/mips/ar7/platform.c
+++ b/arch/mips/ar7/platform.c
-@@ -199,7 +199,7 @@ static struct resource physmap_flash_res
+@@ -199,11 +199,14 @@ static struct resource physmap_flash_res
.name = "mem",
.flags = IORESOURCE_MEM,
.start = 0x10000000,
@@ -30,4 +19,11 @@
+ .end = 0x11ffffff,
};
++static const char *ar7_probe_types[] = { "ar7part", NULL };
++
static struct physmap_flash_data physmap_flash_data = {
+ .width = 2,
++ .part_probe_types = ar7_probe_types,
+ };
+
+ static struct platform_device physmap_flash = {