aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/apm821xx
diff options
context:
space:
mode:
authorPetr Štetiar <ynezz@true.cz>2020-07-27 12:30:41 +0200
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-08-20 14:19:39 +0200
commita14f5bb4bd263c21e103f13279d0c2ff03e48fe5 (patch)
tree18eecef0be1356f014d81b0427471ae18c8839c2 /target/linux/apm821xx
parentcc75344044e5c16cd4994d824db5779a5ac057c2 (diff)
downloadupstream-a14f5bb4bd263c21e103f13279d0c2ff03e48fe5.tar.gz
upstream-a14f5bb4bd263c21e103f13279d0c2ff03e48fe5.tar.bz2
upstream-a14f5bb4bd263c21e103f13279d0c2ff03e48fe5.zip
treewide: use wpad-basic-wolfssl as default
In order to support SAE/WPA3-Personal in default images. Replace almost all occurencies of wpad-basic and wpad-mini with wpad-basic-wolfssl for consistency. Keep out ar71xx from the list as it won't be in the next release and would only make backports harder. Build-tested (build-bot settings): ath79: generic, ramips: mt7620/mt76x8/rt305x, lantiq: xrx200/xway, sunxi: a53 Signed-off-by: Petr Štetiar <ynezz@true.cz> [rebase, extend commit message] Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target/linux/apm821xx')
-rw-r--r--target/linux/apm821xx/image/sata.mk2
-rw-r--r--target/linux/apm821xx/nand/target.mk2
-rw-r--r--target/linux/apm821xx/sata/profiles/00-default.mk2
3 files changed, 3 insertions, 3 deletions
diff --git a/target/linux/apm821xx/image/sata.mk b/target/linux/apm821xx/image/sata.mk
index 6fe8324b93..bcb612c22f 100644
--- a/target/linux/apm821xx/image/sata.mk
+++ b/target/linux/apm821xx/image/sata.mk
@@ -6,7 +6,7 @@ endef
define Device/wd_mybooklive
DEVICE_VENDOR := Western Digital
DEVICE_MODEL := My Book Live Series (Single + Duo)
- DEVICE_PACKAGES := kmod-usb-dwc2 kmod-usb-ledtrig-usbport kmod-usb-storage kmod-fs-vfat wpad-basic
+ DEVICE_PACKAGES := kmod-usb-dwc2 kmod-usb-ledtrig-usbport kmod-usb-storage kmod-fs-vfat wpad-basic-wolfssl
SUPPORTED_DEVICES += mbl wd,mybooklive-duo
BLOCKSIZE := 1k
DTB_SIZE := 16384
diff --git a/target/linux/apm821xx/nand/target.mk b/target/linux/apm821xx/nand/target.mk
index 16475307d7..d40b0fbc19 100644
--- a/target/linux/apm821xx/nand/target.mk
+++ b/target/linux/apm821xx/nand/target.mk
@@ -1,7 +1,7 @@
BOARDNAME:=Devices with NAND flash (Routers)
FEATURES += nand pcie ramdisk squashfs usb
-DEFAULT_PACKAGES += kmod-ath9k swconfig wpad-basic
+DEFAULT_PACKAGES += kmod-ath9k swconfig wpad-basic-wolfssl
define Target/Description
Build firmware images for APM821XX boards with NAND flash.
diff --git a/target/linux/apm821xx/sata/profiles/00-default.mk b/target/linux/apm821xx/sata/profiles/00-default.mk
index db48353bf2..887741abd3 100644
--- a/target/linux/apm821xx/sata/profiles/00-default.mk
+++ b/target/linux/apm821xx/sata/profiles/00-default.mk
@@ -8,7 +8,7 @@
define Profile/Default
NAME:=Default Profile
PRIORITY:=1
- PACKAGES := kmod-usb-dwc2 kmod-usb-ledtrig-usbport kmod-usb-storage kmod-fs-vfat wpad-basic
+ PACKAGES := kmod-usb-dwc2 kmod-usb-ledtrig-usbport kmod-usb-storage kmod-fs-vfat wpad-basic-wolfssl
endef
define Profile/Default/Description