aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/apm821xx
diff options
context:
space:
mode:
authorChristian Lamparter <chunkeey@gmail.com>2020-08-12 19:52:08 +0200
committerChristian Lamparter <chunkeey@gmail.com>2020-08-29 17:14:49 +0200
commit1640e71e8e1b3293a545e26ea5b17ddcbdb622e1 (patch)
treedb4094d69b87855bc9ca15ca061863228a9339ae /target/linux/apm821xx
parent9153955095f01a7ac5f2659a671f0229cbad3507 (diff)
downloadupstream-1640e71e8e1b3293a545e26ea5b17ddcbdb622e1.tar.gz
upstream-1640e71e8e1b3293a545e26ea5b17ddcbdb622e1.tar.bz2
upstream-1640e71e8e1b3293a545e26ea5b17ddcbdb622e1.zip
apm821xx: WNDR4700: delete wndr4700 board file
Thanks to the PCIE OF enumeration patch, this is technically no longer needed. Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
Diffstat (limited to 'target/linux/apm821xx')
-rw-r--r--target/linux/apm821xx/config-5.41
-rw-r--r--target/linux/apm821xx/dts/netgear-wndr4700.dts2
-rw-r--r--target/linux/apm821xx/files/arch/powerpc/platforms/44x/wndr4700.c80
-rw-r--r--target/linux/apm821xx/nand/config-default1
-rw-r--r--target/linux/apm821xx/patches-5.4/202-add-netgear-wndr4700-support.patch32
5 files changed, 1 insertions, 115 deletions
diff --git a/target/linux/apm821xx/config-5.4 b/target/linux/apm821xx/config-5.4
index d54eb95d14..0f59e9f8ff 100644
--- a/target/linux/apm821xx/config-5.4
+++ b/target/linux/apm821xx/config-5.4
@@ -334,7 +334,6 @@ CONFIG_VDSO32=y
# CONFIG_VIRT_CPU_ACCOUNTING_NATIVE is not set
# CONFIG_WARP is not set
CONFIG_WATCHDOG_CORE=y
-# CONFIG_WNDR4700 is not set
# CONFIG_XILINX_SYSACE is not set
# CONFIG_XILINX_VIRTEX440_GENERIC_BOARD is not set
CONFIG_XZ_DEC_BCJ=y
diff --git a/target/linux/apm821xx/dts/netgear-wndr4700.dts b/target/linux/apm821xx/dts/netgear-wndr4700.dts
index a1c23896a1..039c68f30f 100644
--- a/target/linux/apm821xx/dts/netgear-wndr4700.dts
+++ b/target/linux/apm821xx/dts/netgear-wndr4700.dts
@@ -15,7 +15,7 @@
/ {
model = "Netgear WNDR4700/WNDR4720 Series";
- compatible = "netgear,wndr4700";
+ compatible = "netgear,wndr4700", "apm,bluestone";
aliases {
serial0 = &UART0;
diff --git a/target/linux/apm821xx/files/arch/powerpc/platforms/44x/wndr4700.c b/target/linux/apm821xx/files/arch/powerpc/platforms/44x/wndr4700.c
deleted file mode 100644
index ff6137e2a4..0000000000
--- a/target/linux/apm821xx/files/arch/powerpc/platforms/44x/wndr4700.c
+++ /dev/null
@@ -1,80 +0,0 @@
-/*
- * Netgear Centria N900 WNDR4700/WNDR4720 platform support
- *
- * This program is free software; you can redistribute it and/or modify it
- * under the terms of the GNU General Public License as published by the
- * Free Software Foundation; version 2 of the License.
- *
- * This implemention is based on the simple platform support for the
- * PowerPC 44x chips.
- */
-
-#include <asm/machdep.h>
-#include <asm/pci-bridge.h>
-#include <asm/ppc4xx.h>
-#include <asm/prom.h>
-#include <asm/time.h>
-#include <asm/udbg.h>
-#include <asm/uic.h>
-
-#include <linux/init.h>
-#include <linux/of_platform.h>
-#include <linux/pci.h>
-#include <linux/platform_device.h>
-#include <linux/ath9k_platform.h>
-#include <linux/firmware.h>
-#include <linux/delay.h>
-#include <asm/unaligned.h>
-
-static const struct of_device_id ppc44x_of_bus[] __initconst = {
- { .compatible = "ibm,plb4", },
- { .compatible = "ibm,opb", },
- { .compatible = "ibm,ebc", },
- { .compatible = "simple-bus", },
- {},
-};
-
-static int __init ppc44x_device_probe(void)
-{
- of_platform_bus_probe(NULL, ppc44x_of_bus, NULL);
-
- return 0;
-}
-machine_device_initcall(wndr4700, ppc44x_device_probe);
-
-static char *board[] __initdata = {
- "netgear,wndr4700",
-};
-
-static int __init ppc44x_probe(void)
-{
- unsigned long root = of_get_flat_dt_root();
- int i = 0;
-
- pcie_bus_config = PCIE_BUS_PEER2PEER; /* force 128 Byte MPS */
-
- for (i = 0; i < ARRAY_SIZE(board); i++) {
- if (of_flat_dt_is_compatible(root, board[i])) {
- pci_set_flags(PCI_REASSIGN_ALL_RSRC); /* PCI_PROBE_ONLY */
- return 1;
- }
- }
-
- return 0;
-}
-
-define_machine(wndr4700) {
- .name = "WNDR4700 Platform",
- .probe = ppc44x_probe,
- .progress = udbg_progress,
- .init_IRQ = uic_init_tree,
- .get_irq = uic_get_irq,
- .restart = ppc4xx_reset_system,
- .calibrate_decr = generic_calibrate_decr,
-};
-
-static int __init wndr4700_ath9k_eeprom_load(void)
-{
- return 0;
-}
-machine_device_initcall(wndr4700, wndr4700_ath9k_eeprom_load);
diff --git a/target/linux/apm821xx/nand/config-default b/target/linux/apm821xx/nand/config-default
index f53167f75b..e1874f6164 100644
--- a/target/linux/apm821xx/nand/config-default
+++ b/target/linux/apm821xx/nand/config-default
@@ -48,5 +48,4 @@ CONFIG_SENSORS_LM90=y
CONFIG_SENSORS_TC654=y
CONFIG_SWCONFIG=y
CONFIG_SWCONFIG_LEDS=y
-CONFIG_WNDR4700=y
diff --git a/target/linux/apm821xx/patches-5.4/202-add-netgear-wndr4700-support.patch b/target/linux/apm821xx/patches-5.4/202-add-netgear-wndr4700-support.patch
deleted file mode 100644
index b0619852b9..0000000000
--- a/target/linux/apm821xx/patches-5.4/202-add-netgear-wndr4700-support.patch
+++ /dev/null
@@ -1,32 +0,0 @@
---- a/arch/powerpc/platforms/44x/Makefile
-+++ b/arch/powerpc/platforms/44x/Makefile
-@@ -4,6 +4,7 @@ ifneq ($(CONFIG_PPC4xx_CPM),y)
- obj-y += idle.o
- endif
- obj-$(CONFIG_PPC44x_SIMPLE) += ppc44x_simple.o
-+obj-$(CONFIG_WNDR4700) += wndr4700.o
- obj-$(CONFIG_EBONY) += ebony.o
- obj-$(CONFIG_SAM440EP) += sam440ep.o
- obj-$(CONFIG_WARP) += warp.o
---- a/arch/powerpc/platforms/44x/Kconfig
-+++ b/arch/powerpc/platforms/44x/Kconfig
-@@ -243,6 +243,19 @@ config ICON
- help
- This option enables support for the AMCC PPC440SPe evaluation board.
-
-+config WNDR4700
-+ bool "WNDR4700"
-+ depends on 44x
-+ default n
-+ select APM821xx
-+ select PCI_MSI
-+ select PPC4xx_MSI
-+ select PPC4xx_PCI_EXPRESS
-+ select IBM_EMAC_RGMII
-+ select 460EX
-+ help
-+ This option enables support for the Netgear WNDR4700/WNDR4720 board.
-+
- config XILINX_VIRTEX440_GENERIC_BOARD
- bool "Generic Xilinx Virtex 5 FXT board support"
- depends on 44x