aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/apm821xx/image/Makefile
diff options
context:
space:
mode:
authorChris Blake <chrisrblake93@gmail.com>2017-03-31 04:31:21 -0500
committerFelix Fietkau <nbd@nbd.name>2017-04-26 11:34:14 +0200
commitd1c3a9485a90fff9bf7083faba4138e14dcdae7d (patch)
tree516b1fd010c53bb639295f2e6b5fadbb11cdffd9 /target/linux/apm821xx/image/Makefile
parent837285b83221963739cda81911d8004f30f9afb0 (diff)
downloadupstream-d1c3a9485a90fff9bf7083faba4138e14dcdae7d.tar.gz
upstream-d1c3a9485a90fff9bf7083faba4138e14dcdae7d.tar.bz2
upstream-d1c3a9485a90fff9bf7083faba4138e14dcdae7d.zip
apm821xx: Add default packages to NAND target
This moves core router packages to the NAND target, to ensure they are applied to all images. This change is being done due to an issue found when flashing the MX60W image, which came without these when built as a multi image. Signed-off-by: Chris Blake <chrisrblake93@gmail.com>
Diffstat (limited to 'target/linux/apm821xx/image/Makefile')
-rw-r--r--target/linux/apm821xx/image/Makefile11
1 files changed, 5 insertions, 6 deletions
diff --git a/target/linux/apm821xx/image/Makefile b/target/linux/apm821xx/image/Makefile
index 355333695d..1dae2b6636 100644
--- a/target/linux/apm821xx/image/Makefile
+++ b/target/linux/apm821xx/image/Makefile
@@ -69,7 +69,7 @@ endef
define Device/mr24
DEVICE_TITLE := Cisco Meraki MR24
- DEVICE_PACKAGES := kmod-spi-gpio kmod-ath9k wpad-mini
+ DEVICE_PACKAGES := kmod-spi-gpio
DEVICE_PROFILE := MR24
DEVICE_DTS := MR24
BLOCKSIZE := 63k
@@ -89,8 +89,8 @@ TARGET_DEVICES += mr24
define Device/mx60
DEVICE_TITLE := Cisco Meraki MX60
- DEVICE_PACKAGES := kmod-spi-gpio swconfig kmod-usb-ledtrig-usbport \
- kmod-usb-dwc2 kmod-usb-storage block-mount
+ DEVICE_PACKAGES := kmod-spi-gpio kmod-usb-ledtrig-usbport kmod-usb-dwc2 \
+ kmod-usb-storage block-mount
DEVICE_PROFILE := MX60
DEVICE_DTS := MX60
BLOCKSIZE := 63k
@@ -115,7 +115,6 @@ TARGET_DEVICES += mx60
define Device/mx60w
$(Device/mx60)
DEVICE_TITLE := Cisco Meraki MX60W
- DEVICE_PACKAGES += kmod-ath9k wpad-mini
endef
TARGET_DEVICES += mx60w
@@ -160,10 +159,10 @@ endef
define Device/WNDR4700
DEVICE_TITLE := Netgear Centria N900 WNDR4700/WNDR4720
DEVICE_PACKAGES := badblocks block-mount e2fsprogs \
- kmod-ath9k kmod-dm kmod-fs-ext4 kmod-fs-vfat kmod-usb-ledtrig-usbport \
+ kmod-dm kmod-fs-ext4 kmod-fs-vfat kmod-usb-ledtrig-usbport \
kmod-md-mod kmod-nls-cp437 kmod-nls-iso8859-1 kmod-nls-iso8859-15 \
kmod-nls-utf8 kmod-usb3 kmod-usb-dwc2 kmod-usb-storage \
- partx-utils swconfig wpad-mini
+ partx-utils
DEVICE_NAME := wndr4700
DEVICE_PROFILE := wndr4700
DEVICE_DTS := wndr4700