aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/apm821xx/image/Makefile
diff options
context:
space:
mode:
authorChristian Lamparter <chunkeey@gmail.com>2018-07-29 11:55:15 +0200
committerJohn Crispin <john@phrozen.org>2018-07-30 08:11:56 +0200
commitaed4799d6d05d89dbca1bd5f14cc3d09ac563f3b (patch)
treee25dae8904f5ae669c619e623bc854666fe5e0de /target/linux/apm821xx/image/Makefile
parent7516a960113d512cb2909f40bd07caf2a6c547b1 (diff)
downloadupstream-aed4799d6d05d89dbca1bd5f14cc3d09ac563f3b.tar.gz
upstream-aed4799d6d05d89dbca1bd5f14cc3d09ac563f3b.tar.bz2
upstream-aed4799d6d05d89dbca1bd5f14cc3d09ac563f3b.zip
apm821xx: build squashfs-rootfs images for the MBL
This patch adds support for squashfs as the root filesystem. advantages: - migrate from a existing -ext4 installation and back with the sysupgrade utility - existing partition layout will not be lost during switch - slightly smaller image size as compared to the -ext4 image. disadvantages: - needs f2fs + tools. This is because fstools rootdisk.c decides based on the partition size (currently root partitions > 100 MiB) f2fs is used as the rootfs_data filesystem. - rootfs_data is placed into the rootfs partition after the squashfs. This makes it difficult for tools that expect a /dev/sda${X} device. It also makes it difficult for data recovery tools as they might not expect to find a embedded partition or will be slightly confused. ... or will not support f2fs. For people with existing build configurations: make sure to include mkf2fs and f2fsck packages into the image. Otherwise the new -squashfs image will only boot from the ram-overlay. Note: All overlay data (configurations/all installed packages/...) will be placed in inside the rootfs partition (i.e. /dev/sda2) just after the squashfs image. Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
Diffstat (limited to 'target/linux/apm821xx/image/Makefile')
-rw-r--r--target/linux/apm821xx/image/Makefile5
1 files changed, 2 insertions, 3 deletions
diff --git a/target/linux/apm821xx/image/Makefile b/target/linux/apm821xx/image/Makefile
index 9d9c0e5ace..bfc6562431 100644
--- a/target/linux/apm821xx/image/Makefile
+++ b/target/linux/apm821xx/image/Makefile
@@ -211,7 +211,7 @@ define Build/boot-img
endef
define Build/hdd-img
- ./mbl_gen_hdd_img.sh $@ $@.boot $(IMAGE_ROOTFS)
+ ./mbl_gen_hdd_img.sh $@ $@.boot $(IMAGE_ROOTFS) $(BOOT_SIZE) $(CONFIG_TARGET_ROOTFS_PARTSIZE)
endef
define Device/wd_mybooklive
@@ -219,7 +219,6 @@ define Device/wd_mybooklive
DEVICE_PACKAGES := kmod-usb-dwc2 kmod-usb-ledtrig-usbport kmod-usb-storage kmod-fs-vfat wpad-mini
DEVICE_DTS := wd-mybooklive
SUPPORTED_DEVICES += mbl wd_mybooklive-duo
- IMAGE_SIZE := 48m
BLOCKSIZE := 1k
DTB_SIZE := 16384
KERNEL := kernel-bin | dtb | gzip | uImage gzip
@@ -227,7 +226,7 @@ define Device/wd_mybooklive
BOOT_SIZE := 8
IMAGES := rootfs.img.gz kernel.dtb
DEVICE_DTB := apollo3g.dtb
- FILESYSTEMS := ext4
+ FILESYSTEMS := ext4 squashfs
IMAGE/kernel.dtb := export-dtb
IMAGE/rootfs.img.gz := boot-script | boot-img | hdd-img | gzip | append-metadata
endef