aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/apm821xx/image/Makefile
diff options
context:
space:
mode:
authorChristian Lamparter <chunkeey@gmail.com>2018-07-16 22:56:36 +0200
committerMathias Kresin <dev@kresin.me>2018-07-19 18:58:24 +0200
commit9b47aa93c76ba87b7d84dacd2c881cef6334e3f5 (patch)
tree30ec17c349a1248a8d3b8403392d38a185b92d12 /target/linux/apm821xx/image/Makefile
parentc4f09fc9f8e97b11519e52d2f1e6a7bc02e4d2be (diff)
downloadupstream-9b47aa93c76ba87b7d84dacd2c881cef6334e3f5.tar.gz
upstream-9b47aa93c76ba87b7d84dacd2c881cef6334e3f5.tar.bz2
upstream-9b47aa93c76ba87b7d84dacd2c881cef6334e3f5.zip
apm821xx: unify My Book Live Single + Duo images
By takimata: "Come to think of it, an MBL Single board boots up just fine on an MBL Duo image, and the MBL Single board identifies completely identical to the MBL Duo (Board: Apollo-3G - APM82181 Board, 2*SATA, 1*USB). I wonder if there is any downside to just using the MBL Duo firmware on a MBL Single. I wonder if the two firmwares could even be unified." <https://forum.lede-project.org/t/wd-mybook-live-duo-two-disks/16195/9> Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
Diffstat (limited to 'target/linux/apm821xx/image/Makefile')
-rw-r--r--target/linux/apm821xx/image/Makefile23
1 files changed, 5 insertions, 18 deletions
diff --git a/target/linux/apm821xx/image/Makefile b/target/linux/apm821xx/image/Makefile
index 1e94a40918..9d9c0e5ace 100644
--- a/target/linux/apm821xx/image/Makefile
+++ b/target/linux/apm821xx/image/Makefile
@@ -214,7 +214,11 @@ define Build/hdd-img
./mbl_gen_hdd_img.sh $@ $@.boot $(IMAGE_ROOTFS)
endef
-define Device/MyBookLiveDefault
+define Device/wd_mybooklive
+ DEVICE_TITLE := Western Digital My Book Live Series (Single + Duo)
+ DEVICE_PACKAGES := kmod-usb-dwc2 kmod-usb-ledtrig-usbport kmod-usb-storage kmod-fs-vfat wpad-mini
+ DEVICE_DTS := wd-mybooklive
+ SUPPORTED_DEVICES += mbl wd_mybooklive-duo
IMAGE_SIZE := 48m
BLOCKSIZE := 1k
DTB_SIZE := 16384
@@ -228,25 +232,8 @@ define Device/MyBookLiveDefault
IMAGE/rootfs.img.gz := boot-script | boot-img | hdd-img | gzip | append-metadata
endef
-define Device/wd_mybooklive
-$(Device/MyBookLiveDefault)
- DEVICE_TITLE := Western Digital My Book Live
- DEVICE_DTS := wd-mybooklive
- SUPPORTED_DEVICES += mbl
-endef
-
TARGET_DEVICES += wd_mybooklive
-define Device/wd_mybooklive-duo
-$(Device/MyBookLiveDefault)
- DEVICE_TITLE := Western Digital My Book Live Duo
- DEVICE_PACKAGES := kmod-usb-dwc2 kmod-usb-ledtrig-usbport kmod-usb-storage kmod-fs-vfat wpad-mini
- DEVICE_DTS := wd-mybooklive-duo
- SUPPORTED_DEVICES += mbl
-endef
-
-TARGET_DEVICES += wd_mybooklive-duo
-
endif
$(eval $(call BuildImage))