aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/apm821xx/image/Makefile
diff options
context:
space:
mode:
authorChristian Lamparter <chunkeey@gmail.com>2017-12-17 14:59:53 +0100
committerMathias Kresin <dev@kresin.me>2017-12-21 01:05:16 +0100
commit7c2106696de79d51ce6d06ecd8c43eeade791b10 (patch)
tree95f9c9cdaf6d2a6de7f5d5985db19bfd73939b33 /target/linux/apm821xx/image/Makefile
parent198da20401f2216d92fb8a1539abcd4af743e0d8 (diff)
downloadupstream-7c2106696de79d51ce6d06ecd8c43eeade791b10.tar.gz
upstream-7c2106696de79d51ce6d06ecd8c43eeade791b10.tar.bz2
upstream-7c2106696de79d51ce6d06ecd8c43eeade791b10.zip
apm821xx: explicitly build the rootfs.img.gz target
The commit 87b668765e1 ("image: when using the new image build code, gzip ext4 images by default") forced that all targets that select the ext4 as the root filesystem to always compress the generated rootfs. This is fine, but this method doesn't not allow to append the metadata on a per-target base. Therefore this patch changes the rootfs image production rule to generate the gzip step manually. This way the metadata can be appended at a later date. Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
Diffstat (limited to 'target/linux/apm821xx/image/Makefile')
-rw-r--r--target/linux/apm821xx/image/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/target/linux/apm821xx/image/Makefile b/target/linux/apm821xx/image/Makefile
index ee85292d57..ebc6a051cc 100644
--- a/target/linux/apm821xx/image/Makefile
+++ b/target/linux/apm821xx/image/Makefile
@@ -217,11 +217,11 @@ define Device/MyBookLiveDefault
KERNEL := kernel-bin | dtb | gzip | uImage gzip
KERNEL_INITRAMFS := kernel-bin | dtb | gzip | uImage gzip
BOOT_SIZE := 8
- IMAGES := rootfs.img kernel.dtb
+ IMAGES := rootfs.img.gz kernel.dtb
DEVICE_DTB := apollo3g.dtb
FILESYSTEMS := ext4
IMAGE/kernel.dtb := export-dtb
- IMAGE/rootfs.img := boot-script | boot-img | hdd-img
+ IMAGE/rootfs.img.gz := boot-script | boot-img | hdd-img | gzip
endef
define Device/MyBookLiveSingle