aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/apm821xx/image/Makefile
diff options
context:
space:
mode:
authorMathias Kresin <dev@kresin.me>2018-04-20 06:30:46 +0200
committerMathias Kresin <dev@kresin.me>2018-04-20 20:58:52 +0200
commit74a0d8cd92c7e753c6a342a7b90151ec042a03c5 (patch)
treef0fb63e26b872c1e799d8cf729182df3a2d8861d /target/linux/apm821xx/image/Makefile
parent5950ab067bcc6ffa9ab6bb0c28c8d9ca45d34eb7 (diff)
downloadupstream-74a0d8cd92c7e753c6a342a7b90151ec042a03c5.tar.gz
upstream-74a0d8cd92c7e753c6a342a7b90151ec042a03c5.tar.bz2
upstream-74a0d8cd92c7e753c6a342a7b90151ec042a03c5.zip
build: consolidate fake uImage header build commands
Merge the two existing functions and use a parameter for the type header field. It updates the syntax of the former mpc85xx fake ramdisk header command to be compatible with mkimage from u-boot 2018.03 and fixes the build error spotted by the build bot. Signed-off-by: Mathias Kresin <dev@kresin.me>
Diffstat (limited to 'target/linux/apm821xx/image/Makefile')
-rw-r--r--target/linux/apm821xx/image/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/apm821xx/image/Makefile b/target/linux/apm821xx/image/Makefile
index 4cfbea4cbd..094c9e47de 100644
--- a/target/linux/apm821xx/image/Makefile
+++ b/target/linux/apm821xx/image/Makefile
@@ -171,7 +171,7 @@ define Device/netgear_wndr4700
# append a fake/empty rootfs to fool netgear's uboot
# CHECK_DNI_FIRMWARE_ROOTFS_INTEGRITY in do_chk_dniimg()
KERNEL := kernel-bin | lzma | uImage lzma | pad-offset $$(BLOCKSIZE) 64 | \
- append-uImage-fakeroot-hdr | dtb | create-uImage-dtb | prepend-dtb
+ append-uImage-fakehdr filesystem | dtb | create-uImage-dtb | prepend-dtb
KERNEL_INITRAMFS := kernel-bin | gzip | dtb | MuImage-initramfs gzip
IMAGE/factory.img := append-kernel | pad-to $$$$(KERNEL_SIZE) | append-ubi | \
netgear-dni | check-size $$$$(IMAGE_SIZE)