aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/amazon-2.6/patches/100-board.patch
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2007-07-23 22:10:11 +0000
committerJohn Crispin <john@openwrt.org>2007-07-23 22:10:11 +0000
commit7470547083506f15a893165e8e312a9bf4eac893 (patch)
treed996fa1661834d1fd45591bae6b977ad894c4530 /target/linux/amazon-2.6/patches/100-board.patch
parentbee289741948605001e405bb1fdb92b60b36b17c (diff)
downloadupstream-7470547083506f15a893165e8e312a9bf4eac893.tar.gz
upstream-7470547083506f15a893165e8e312a9bf4eac893.tar.bz2
upstream-7470547083506f15a893165e8e312a9bf4eac893.zip
initial merge of infineon code for amazon, pci is still broken a bit. a big thank you goes to infineon for providing info and reference code
SVN-Revision: 8137
Diffstat (limited to 'target/linux/amazon-2.6/patches/100-board.patch')
-rw-r--r--target/linux/amazon-2.6/patches/100-board.patch63
1 files changed, 63 insertions, 0 deletions
diff --git a/target/linux/amazon-2.6/patches/100-board.patch b/target/linux/amazon-2.6/patches/100-board.patch
new file mode 100644
index 0000000000..9b29141239
--- /dev/null
+++ b/target/linux/amazon-2.6/patches/100-board.patch
@@ -0,0 +1,63 @@
+diff -urN linux.old/arch/mips/Kconfig linux.dev/arch/mips/Kconfig
+--- linux.old/arch/mips/Kconfig 2007-02-02 23:55:52.912446784 +0100
++++ linux.dev/arch/mips/Kconfig 2007-02-03 21:50:25.262027104 +0100
+@@ -145,6 +145,17 @@
+ note that a kernel built with this option selected will not be
+ able to run on normal units.
+
++config AMAZON
++ bool "Amazon support (EXPERIMENTAL)"
++ depends on EXPERIMENTAL
++ select DMA_NONCOHERENT
++ select IRQ_CPU
++ select SYS_HAS_CPU_MIPS32_R1
++ select HAVE_STD_PC_SERIAL_PORT
++ select SYS_SUPPORTS_BIG_ENDIAN
++ select SYS_SUPPORTS_32BIT_KERNEL
++ select SYS_HAS_EARLY_PRINTK
++
+ config MIPS_COBALT
+ bool "Cobalt Server"
+ select DMA_NONCOHERENT
+@@ -766,6 +776,7 @@
+
+ endchoice
+
++source "arch/mips/amazon/Kconfig"
+ source "arch/mips/ddb5xxx/Kconfig"
+ source "arch/mips/gt64120/ev64120/Kconfig"
+ source "arch/mips/jazz/Kconfig"
+diff -urN linux.old/arch/mips/Makefile linux.dev/arch/mips/Makefile
+--- linux.old/arch/mips/Makefile 2007-02-02 23:55:52.913446632 +0100
++++ linux.dev/arch/mips/Makefile 2007-02-03 17:40:29.193776000 +0100
+@@ -267,6 +267,13 @@
+ load-$(CONFIG_MIPS_XXS1500) += 0xffffffff80100000
+
+ #
++# Infineon AMAZON
++#
++core-$(CONFIG_AMAZON) += arch/mips/amazon/
++cflags-$(CONFIG_AMAZON) += -Iinclude/asm-mips/mach-amazon
++load-$(CONFIG_AMAZON) += 0xffffffff80002000
++
++#
+ # Cobalt Server
+ #
+ core-$(CONFIG_MIPS_COBALT) += arch/mips/cobalt/
+diff -urN linux.old/include/asm-mips/bootinfo.h linux.dev/include/asm-mips/bootinfo.h
+--- linux.old/include/asm-mips/bootinfo.h 2007-02-02 23:55:52.913446632 +0100
++++ linux.dev/include/asm-mips/bootinfo.h 2007-02-03 17:51:02.531494032 +0100
+@@ -212,6 +212,12 @@
+ #define MACH_GROUP_NEC_EMMA2RH 25 /* NEC EMMA2RH (was 23) */
+ #define MACH_NEC_MARKEINS 0 /* NEC EMMA2RH Mark-eins */
+
++/*
++ * Valid machtype for group ATHEROS
++ */
++#define MACH_GROUP_INFINEON 27
++#define MACH_INFINEON_AMAZON 0
++
+ #define CL_SIZE COMMAND_LINE_SIZE
+
+ const char *get_system_type(void);
+