aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/adm5120/router_le/profiles
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2019-03-25 15:10:39 +0100
committerHauke Mehrtens <hauke@hauke-m.de>2019-05-03 21:27:12 +0200
commit2d0a2ff1e0c386bcb3b1ae0a0924624e8cb20b37 (patch)
treefa266fc04fd47b42cbc0bd7ae6e6d51c48f64eb2 /target/linux/adm5120/router_le/profiles
parent49dca520fb900410a436baa58404539aa1e10381 (diff)
downloadupstream-2d0a2ff1e0c386bcb3b1ae0a0924624e8cb20b37.tar.gz
upstream-2d0a2ff1e0c386bcb3b1ae0a0924624e8cb20b37.tar.bz2
upstream-2d0a2ff1e0c386bcb3b1ae0a0924624e8cb20b37.zip
adm5120: Remove unmaintained target
This target only supports kernel 3.18, which is not supported in OpenWrt any more for multiple releases. It also looks like there is no active maintainer for this target. Remove the code and all the packages which are only used by this target. To add this target to OpenWrt again port it to a recent and supported kernel version. Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
Diffstat (limited to 'target/linux/adm5120/router_le/profiles')
-rw-r--r--target/linux/adm5120/router_le/profiles/010-Generic.mk28
-rw-r--r--target/linux/adm5120/router_le/profiles/Cellvision.mk146
-rw-r--r--target/linux/adm5120/router_le/profiles/Compex.mk37
-rw-r--r--target/linux/adm5120/router_le/profiles/Edimax.mk47
-rw-r--r--target/linux/adm5120/router_le/profiles/Infineon.mk27
-rw-r--r--target/linux/adm5120/router_le/profiles/Motorola.mk16
-rw-r--r--target/linux/adm5120/router_le/profiles/Osbridge.mk16
7 files changed, 0 insertions, 317 deletions
diff --git a/target/linux/adm5120/router_le/profiles/010-Generic.mk b/target/linux/adm5120/router_le/profiles/010-Generic.mk
deleted file mode 100644
index 6c3e5f30eb..0000000000
--- a/target/linux/adm5120/router_le/profiles/010-Generic.mk
+++ /dev/null
@@ -1,28 +0,0 @@
-#
-# Copyright (C) 2007 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/Generic
- NAME:=Generic (default)
- PACKAGES:=
-endef
-
-define Profile/Generic/Description
- Generic package set compatible with most boards.
-endef
-
-define Profile/EB-214A
- NAME:=Generic EB-214A
- PACKAGES:=-wpad-mini -admswconfig -kmod-usb-adm5120 -kmod-ledtrig-adm5120-switch -dnsmasq kmod-usb-uhci kmod-usb2
-endef
-
-define Profile/EB-214A/Description
- Package set optimized for generic EB-214A boards.
-endef
-
-$(eval $(call Profile,Generic))
-$(eval $(call Profile,EB-214A))
-
diff --git a/target/linux/adm5120/router_le/profiles/Cellvision.mk b/target/linux/adm5120/router_le/profiles/Cellvision.mk
deleted file mode 100644
index 4093b4f493..0000000000
--- a/target/linux/adm5120/router_le/profiles/Cellvision.mk
+++ /dev/null
@@ -1,146 +0,0 @@
-#
-# Copyright (C) 2007-2008 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/CAS630
- NAME:=Cellvision CAS-630 IP camera (Experimental)
- # TODO: add default packages
- PACKAGES:=-wpad-mini
-endef
-
-define Profile/CAS630/Description
- Package set optimized for the Cellvision CAS-630 device.
-endef
-
-define Profile/CAS630W
- NAME:=Cellvision CAS-630W IP camera (Experimental)
- # TODO: add default packages
- PACKAGES:=-wpad-mini
-endef
-
-define Profile/CAS630W/Description
- Package set optimized for the Cellvision CAS-630W device.
-endef
-
-define Profile/CAS670
- NAME:=Cellvision CAS-670 IP camera (Experimental)
- # TODO: add default packages
- PACKAGES:=-wpad-mini
-endef
-
-define Profile/CAS670/Description
- Package set optimized for the Cellvision CAS-670 device.
-endef
-
-define Profile/CAS670W
- NAME:=Cellvision CAS-670W IP camera (Experimental)
- # TODO: add default packages
- PACKAGES:=-wpad-mini
-endef
-
-define Profile/CAS670W/Description
- Package set optimized for the Cellvision CAS-670 device.
-endef
-
-define Profile/CAS700
- NAME:=Cellvision CAS-700 IP camera (Experimental)
- # TODO: add default packages
- PACKAGES:=-wpad-mini
-endef
-
-define Profile/CAS700/Description
- Package set optimized for the Cellvision CAS-700 device.
-endef
-
-define Profile/CAS700W
- NAME:=Cellvision CAS-700W IP camera (Experimental)
- # TODO: add default packages
- PACKAGES:=-wpad-mini
-endef
-
-define Profile/CAS700W/Description
- Package set optimized for the Cellvision CAS-700W device.
-endef
-
-define Profile/CAS771
- NAME:=Cellvision CAS-771 IP camera (Experimental)
- PACKAGES:=-wpad-mini kmod-video-cpia2 kmod-usb-ohci kmod-usb2 kmod-usb-audio
-endef
-
-define Profile/CAS771/Description
- Package set optimized for the Cellvision CAS-771 device.
-endef
-
-define Profile/CAS771W
- NAME:=Cellvision CAS-771W IP camera (Experimental)
- PACKAGES:=-wpad-mini kmod-video-cpia2 kmod-usb-ohci kmod-usb2 kmod-usb-audio kmod-rt2500-pci
-endef
-
-define Profile/CAS771W/Description
- Package set optimized for the Cellvision CAS-771W device.
-endef
-
-define Profile/CAS790
- NAME:=Cellvision CAS-790 IP camera (Experimental)
- # TODO: add default packages
- PACKAGES:=-wpad-mini
-endef
-
-define Profile/CAS790/Description
- Package set optimized for the Cellvision CAS-790 device.
-endef
-
-define Profile/CAS861
- NAME:=Cellvision CAS-861 IP camera (Experimental)
- # TODO: add default packages
- PACKAGES:=-wpad-mini
-endef
-
-define Profile/CAS861/Description
- Package set optimized for the Cellvision CAS-861 device.
-endef
-
-define Profile/CAS861W
- NAME:=Cellvision CAS-861W IP camera (Experimental)
- PACKAGES:=kmod-rt2500-pci
-endef
-
-define Profile/CAS861W/Description
- Package set optimized for the Cellvision CAS-861W device.
-endef
-
-define Profile/NFS101U
- NAME:=Cellvision NFS-101U Network File Server (Experimental)
- PACKAGES:=-wpad-mini kmod-usb-ohci kmod-usb2
-endef
-
-define Profile/NFS101U/Description
- Package set optimized for the Cellvision NFS-101U device.
-endef
-
-define Profile/NFS101WU
- NAME:=Cellvision NFS-101WU Network File Server (Experimental)
- PACKAGES:=-wpad-mini kmod-usb-ohci kmod-usb2
-endef
-
-define Profile/NFS101WU/Description
- Package set optimized for the Cellvision NFS-101WU device.
-endef
-
-$(eval $(call Profile,CAS630))
-$(eval $(call Profile,CAS630W))
-$(eval $(call Profile,CAS670))
-$(eval $(call Profile,CAS670W))
-$(eval $(call Profile,CAS700))
-$(eval $(call Profile,CAS700W))
-$(eval $(call Profile,CAS771))
-$(eval $(call Profile,CAS771W))
-$(eval $(call Profile,CAS790))
-$(eval $(call Profile,CAS861))
-$(eval $(call Profile,CAS861W))
-$(eval $(call Profile,NFS101U))
-$(eval $(call Profile,NFS101WU))
-
diff --git a/target/linux/adm5120/router_le/profiles/Compex.mk b/target/linux/adm5120/router_le/profiles/Compex.mk
deleted file mode 100644
index 79d1f3f914..0000000000
--- a/target/linux/adm5120/router_le/profiles/Compex.mk
+++ /dev/null
@@ -1,37 +0,0 @@
-#
-# Copyright (C) 2007 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/NP27G
- NAME:=Compex NP27G
- PACKAGES:=kmod-ath5k kmod-usb-core kmod-usb-adm5120
-endef
-
-define Profile/NP27G/Description
- Package set optimized for the Compex NP27G.
-endef
-
-define Profile/NP28G
- NAME:=Compex NP28G
- PACKAGES:=kmod-ath5k kmod-usb-core kmod-usb-uhci kmod-usb2
-endef
-
-define Profile/NP28G/Description
- Package set optimized for the Compex NP28G.
-endef
-
-define Profile/WP54
- NAME:=Compex WP54 family
- PACKAGES:=kmod-ath5k
-endef
-
-define Profile/WP54/Description
- Package set optimized for the Compex WP54 family.
-endef
-
-$(eval $(call Profile,NP27G))
-$(eval $(call Profile,NP28G))
-$(eval $(call Profile,WP54))
diff --git a/target/linux/adm5120/router_le/profiles/Edimax.mk b/target/linux/adm5120/router_le/profiles/Edimax.mk
deleted file mode 100644
index 55c295875c..0000000000
--- a/target/linux/adm5120/router_le/profiles/Edimax.mk
+++ /dev/null
@@ -1,47 +0,0 @@
-#
-# Copyright (C) 2007,2008 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/BR6104K
- NAME:=Edimax BR-6104K (Unofficial)
- PACKAGES:=-wpad-mini
-endef
-
-define Profile/BR6104K/Description
- Package set optimized for the Edimax BR-6104K
-endef
-
-define Profile/BR6104KP
- NAME:=Edimax BR-6104KP (Unofficial)
- PACKAGES:=-wpad-mini kmod-usb-core kmod-usb-adm5120
-endef
-
-define Profile/BR6104KP/Description
- Package set optimized for the Edimax BR-6104KP
-endef
-
-define Profile/BR6104WG
- NAME:=Edimax BR-6104Wg (Unofficial, No WiFi)
- PACKAGES:=-wpad-mini
-endef
-
-define Profile/BR6104WG/Description
- Package set optimized for the Edimax BR-6104Wg
-endef
-
-define Profile/BR6114WG
- NAME:=Edimax BR-6114WG (Unofficial, No WiFi)
- PACKAGES:=-wpad-mini
-endef
-
-define Profile/BR6114WG/Description
- Package set optimized for the Edimax BR-6114WG
-endef
-
-$(eval $(call Profile,BR6104K))
-$(eval $(call Profile,BR6104KP))
-$(eval $(call Profile,BR6104WG))
-$(eval $(call Profile,BR6114WG))
diff --git a/target/linux/adm5120/router_le/profiles/Infineon.mk b/target/linux/adm5120/router_le/profiles/Infineon.mk
deleted file mode 100644
index d650406b78..0000000000
--- a/target/linux/adm5120/router_le/profiles/Infineon.mk
+++ /dev/null
@@ -1,27 +0,0 @@
-#
-# Copyright (C) 2008 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/EASY5120RT
- NAME:=Infineon EASY 5120-RT Reference Board
- PACKAGES:=kmod-usb-core kmod-usb-adm5120
-endef
-
-define Profile/EASY5120RT/Description
- Package set optimized for the Infineon EASY 5120-RT Reference Board
-endef
-
-$(eval $(call Profile,EASY5120RT))
-
-define Profile/EASY5120PATA
- NAME:=Infineon EASY 5120P-ATA Reference Board
-endef
-
-define Profile/EASY5120RT/Description
- Package set optimized for the Infineon EASY 5120P-ATA Reference Board
-endef
-
-$(eval $(call Profile,EASY5120PATA))
diff --git a/target/linux/adm5120/router_le/profiles/Motorola.mk b/target/linux/adm5120/router_le/profiles/Motorola.mk
deleted file mode 100644
index e640b81a1f..0000000000
--- a/target/linux/adm5120/router_le/profiles/Motorola.mk
+++ /dev/null
@@ -1,16 +0,0 @@
-#
-# Copyright (C) 2008 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/PMUGW
- NAME:=Motorola Powerline MU Gateway (EXPERIMENTAL)
-endef
-
-define Profile/PMUGW/Description
- Package set optimized for the Motorola Powerline MU Gateway board
-endef
-
-$(eval $(call Profile,PMUGW))
diff --git a/target/linux/adm5120/router_le/profiles/Osbridge.mk b/target/linux/adm5120/router_le/profiles/Osbridge.mk
deleted file mode 100644
index 459d524ba3..0000000000
--- a/target/linux/adm5120/router_le/profiles/Osbridge.mk
+++ /dev/null
@@ -1,16 +0,0 @@
-#
-# Copyright (C) 2007-2009 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/5GXI
- NAME:=Osbridge 5GXi/5XLi (Unofficial)
-endef
-
-define Profile/5GXI/Description
- Package set optimized for the OSBRiDGE 5GXi/5XLi boards.
-endef
-
-$(eval $(call Profile,5GXI))