aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/adm5120/router_be/profiles
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2007-09-11 17:55:08 +0000
committerGabor Juhos <juhosg@openwrt.org>2007-09-11 17:55:08 +0000
commitddec515a092c690fba6fece4c50021b4a648badb (patch)
tree043a476447f79956367214dc7e8a7bdd12ffa0e7 /target/linux/adm5120/router_be/profiles
parent9bf211bb9027e2f87ba56e415cae7cef228e9652 (diff)
downloadupstream-ddec515a092c690fba6fece4c50021b4a648badb.tar.gz
upstream-ddec515a092c690fba6fece4c50021b4a648badb.tar.bz2
upstream-ddec515a092c690fba6fece4c50021b4a648badb.zip
rewrite image generation
SVN-Revision: 8755
Diffstat (limited to 'target/linux/adm5120/router_be/profiles')
-rw-r--r--target/linux/adm5120/router_be/profiles/010-Generic.mk17
-rw-r--r--target/linux/adm5120/router_be/profiles/090-Zyxel.mk17
-rw-r--r--target/linux/adm5120/router_be/profiles/100-Texas.mk6
-rw-r--r--target/linux/adm5120/router_be/profiles/110-Atheros.mk8
-rw-r--r--target/linux/adm5120/router_be/profiles/110-None.mk17
-rw-r--r--target/linux/adm5120/router_be/profiles/200-ZyXEL.mk27
6 files changed, 51 insertions, 41 deletions
diff --git a/target/linux/adm5120/router_be/profiles/010-Generic.mk b/target/linux/adm5120/router_be/profiles/010-Generic.mk
new file mode 100644
index 0000000000..1d477319da
--- /dev/null
+++ b/target/linux/adm5120/router_be/profiles/010-Generic.mk
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2007 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Generic
+ NAME:=Generic (default)
+ PACKAGES:=
+endef
+
+define Profile/Generic/Description
+ Generic package set compatible with most boards.
+endef
+$(eval $(call Profile,Generic))
+
diff --git a/target/linux/adm5120/router_be/profiles/090-Zyxel.mk b/target/linux/adm5120/router_be/profiles/090-Zyxel.mk
deleted file mode 100644
index b0741e84be..0000000000
--- a/target/linux/adm5120/router_be/profiles/090-Zyxel.mk
+++ /dev/null
@@ -1,17 +0,0 @@
-#
-# Copyright (C) 2007 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/Zyxel
- NAME:=Zyxel Prestige P-334/335/335-WT (default)
- PACKAGES:=kmod-acx kmod-usb-core kmod-usb-adm5120
-endef
-
-define Profile/Zyxel/Description
- Package set compatible with the Zyxel prestige P-334/335/335-WT boards
-endef
-$(eval $(call Profile,Zyxel))
-
diff --git a/target/linux/adm5120/router_be/profiles/100-Texas.mk b/target/linux/adm5120/router_be/profiles/100-Texas.mk
index 727a0c0648..af17042b04 100644
--- a/target/linux/adm5120/router_be/profiles/100-Texas.mk
+++ b/target/linux/adm5120/router_be/profiles/100-Texas.mk
@@ -1,13 +1,13 @@
#
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2007 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#
define Profile/Texas
- NAME:=Texas Instruments WiFi
- PACKAGES:=kmod-acx
+ NAME:=Texas Instruments WiFi
+ PACKAGES:=kmod-acx
endef
define Profile/Texas/Description
diff --git a/target/linux/adm5120/router_be/profiles/110-Atheros.mk b/target/linux/adm5120/router_be/profiles/110-Atheros.mk
index cc4a704495..fa95bf3b10 100644
--- a/target/linux/adm5120/router_be/profiles/110-Atheros.mk
+++ b/target/linux/adm5120/router_be/profiles/110-Atheros.mk
@@ -1,17 +1,17 @@
#
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2007 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#
define Profile/Atheros
- NAME:=Atheros WiFi
- PACKAGES:=kmod-madwifi
+ NAME:=Atheros WiFi
+ PACKAGES:=kmod-madwifi
endef
define Profile/Atheros/Description
- Package set compatible with hardware using Atheros WiFi cards
+ Package set compatible with hardware using Atheros WiFi cards.
endef
$(eval $(call Profile,Atheros))
diff --git a/target/linux/adm5120/router_be/profiles/110-None.mk b/target/linux/adm5120/router_be/profiles/110-None.mk
deleted file mode 100644
index 2fcfacde9f..0000000000
--- a/target/linux/adm5120/router_be/profiles/110-None.mk
+++ /dev/null
@@ -1,17 +0,0 @@
-#
-# Copyright (C) 2006 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/None
- NAME:=No WiFi
- PACKAGES:=
-endef
-
-define Profile/None/Description
- Package set without WiFi support
-endef
-$(eval $(call Profile,None))
-
diff --git a/target/linux/adm5120/router_be/profiles/200-ZyXEL.mk b/target/linux/adm5120/router_be/profiles/200-ZyXEL.mk
new file mode 100644
index 0000000000..0af5613a38
--- /dev/null
+++ b/target/linux/adm5120/router_be/profiles/200-ZyXEL.mk
@@ -0,0 +1,27 @@
+#
+# Copyright (C) 2007 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/P-334WT
+ NAME:=ZyXEL Prestige P-334WT
+ PACKAGES:=kmod-acx
+endef
+
+define Profile/P-334WT/Description
+ Package set optimized for the ZyXEL Prestige P-334WT board.
+endef
+
+define Profile/P-335WT
+ NAME:=ZyXEL Prestige P-335WT
+ PACKAGES:=kmod-acx kmod-usb-core kmod-usb-adm5120
+endef
+
+define Profile/P-335WT/Description
+ Package set optimized for the ZyXEL Prestige P-335WT board.
+endef
+
+$(eval $(call Profile,P-334WT))
+$(eval $(call Profile,P-335WT))