aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/adm5120/patches-3.3/310-adm5120_wdt.patch
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2012-04-25 12:57:33 +0000
committerGabor Juhos <juhosg@openwrt.org>2012-04-25 12:57:33 +0000
commit671361c7ea8a260f414046317769d502aaf00d51 (patch)
tree637d9699223fbb75ccd3de8dd0456ff2c97e7350 /target/linux/adm5120/patches-3.3/310-adm5120_wdt.patch
parent43d67fa995bb1b4073d345a08f23b25cf2ee62a1 (diff)
downloadupstream-671361c7ea8a260f414046317769d502aaf00d51.tar.gz
upstream-671361c7ea8a260f414046317769d502aaf00d51.tar.bz2
upstream-671361c7ea8a260f414046317769d502aaf00d51.zip
adm5120: add 3.3 support
Partially based on the 3.1 patches by Hartmut Knaack <knaack.h [at] gmx.de> SVN-Revision: 31474
Diffstat (limited to 'target/linux/adm5120/patches-3.3/310-adm5120_wdt.patch')
-rw-r--r--target/linux/adm5120/patches-3.3/310-adm5120_wdt.patch31
1 files changed, 31 insertions, 0 deletions
diff --git a/target/linux/adm5120/patches-3.3/310-adm5120_wdt.patch b/target/linux/adm5120/patches-3.3/310-adm5120_wdt.patch
new file mode 100644
index 0000000000..ca537ecb78
--- /dev/null
+++ b/target/linux/adm5120/patches-3.3/310-adm5120_wdt.patch
@@ -0,0 +1,31 @@
+--- a/drivers/watchdog/Kconfig
++++ b/drivers/watchdog/Kconfig
+@@ -943,6 +943,18 @@ config RC32434_WDT
+ To compile this driver as a module, choose M here: the
+ module will be called rc32434_wdt.
+
++config ADM5120_WDT
++ tristate "Infineon ADM5120 SoC hardware watchdog"
++ depends on WATCHDOG && ADM5120
++ help
++ This is a driver for hardware watchdog integrated in Infineon
++ ADM5120 SoC. This watchdog simply watches your kernel to make sure
++ it doesn't freeze, and if it does, it reboots your computer after a
++ certain amount of time.
++
++ To compile this driver as a module, choose M here: the module will be
++ called adm5120_wdt.
++
+ config INDYDOG
+ tristate "Indy/I2 Hardware Watchdog"
+ depends on SGI_HAS_INDYDOG
+--- a/drivers/watchdog/Makefile
++++ b/drivers/watchdog/Makefile
+@@ -122,6 +122,7 @@ obj-$(CONFIG_ATH79_WDT) += ath79_wdt.o
+ obj-$(CONFIG_BCM47XX_WDT) += bcm47xx_wdt.o
+ obj-$(CONFIG_BCM63XX_WDT) += bcm63xx_wdt.o
+ obj-$(CONFIG_RC32434_WDT) += rc32434_wdt.o
++obj-$(CONFIG_ADM5120_WDT) += adm5120_wdt.o
+ obj-$(CONFIG_INDYDOG) += indydog.o
+ obj-$(CONFIG_JZ4740_WDT) += jz4740_wdt.o
+ obj-$(CONFIG_WDT_MTX1) += mtx-1_wdt.o