aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/adm5120/patches-3.3/009-adm5120_leds_switch_trigger.patch
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2012-04-25 12:57:33 +0000
committerGabor Juhos <juhosg@openwrt.org>2012-04-25 12:57:33 +0000
commit671361c7ea8a260f414046317769d502aaf00d51 (patch)
tree637d9699223fbb75ccd3de8dd0456ff2c97e7350 /target/linux/adm5120/patches-3.3/009-adm5120_leds_switch_trigger.patch
parent43d67fa995bb1b4073d345a08f23b25cf2ee62a1 (diff)
downloadupstream-671361c7ea8a260f414046317769d502aaf00d51.tar.gz
upstream-671361c7ea8a260f414046317769d502aaf00d51.tar.bz2
upstream-671361c7ea8a260f414046317769d502aaf00d51.zip
adm5120: add 3.3 support
Partially based on the 3.1 patches by Hartmut Knaack <knaack.h [at] gmx.de> SVN-Revision: 31474
Diffstat (limited to 'target/linux/adm5120/patches-3.3/009-adm5120_leds_switch_trigger.patch')
-rw-r--r--target/linux/adm5120/patches-3.3/009-adm5120_leds_switch_trigger.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/target/linux/adm5120/patches-3.3/009-adm5120_leds_switch_trigger.patch b/target/linux/adm5120/patches-3.3/009-adm5120_leds_switch_trigger.patch
new file mode 100644
index 0000000000..5d896e67ac
--- /dev/null
+++ b/target/linux/adm5120/patches-3.3/009-adm5120_leds_switch_trigger.patch
@@ -0,0 +1,22 @@
+--- a/drivers/leds/Kconfig
++++ b/drivers/leds/Kconfig
+@@ -498,4 +498,12 @@ config LEDS_TRIGGER_USBDEV
+ This allows LEDs to be controlled by the presence/activity of
+ an USB device. If unsure, say N.
+
++config LEDS_TRIGGER_ADM5120_SWITCH
++ tristate "LED ADM5120 Switch Port Status Trigger"
++ depends on LEDS_TRIGGERS && ADM5120
++ help
++ This allows LEDs to be controlled by the port states of
++ the ADM5120 built-in Ethernet Switch
++ If unsure, say N.
++
+ endif # NEW_LEDS
+--- a/drivers/leds/Makefile
++++ b/drivers/leds/Makefile
+@@ -60,3 +60,4 @@ obj-$(CONFIG_LEDS_TRIGGER_DEFAULT_ON) +=
+ obj-$(CONFIG_LEDS_TRIGGER_MORSE) += ledtrig-morse.o
+ obj-$(CONFIG_LEDS_TRIGGER_NETDEV) += ledtrig-netdev.o
+ obj-$(CONFIG_LEDS_TRIGGER_USBDEV) += ledtrig-usbdev.o
++obj-$(CONFIG_LEDS_TRIGGER_ADM5120_SWITCH) += ledtrig-adm5120-switch.o