aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/adm5120/patches-3.18/310-adm5120_wdt.patch
diff options
context:
space:
mode:
authorRafał Miłecki <zajec5@gmail.com>2015-02-28 23:39:14 +0000
committerRafał Miłecki <zajec5@gmail.com>2015-02-28 23:39:14 +0000
commit7140ca235c2badffbea119ca587fb70d36574eb5 (patch)
tree79decc4c48d20eb458f033e07b55d7c0f37a7315 /target/linux/adm5120/patches-3.18/310-adm5120_wdt.patch
parent4269bcdf04027fa9a724b107a457f7c508c3a3d0 (diff)
downloadupstream-7140ca235c2badffbea119ca587fb70d36574eb5.tar.gz
upstream-7140ca235c2badffbea119ca587fb70d36574eb5.tar.bz2
upstream-7140ca235c2badffbea119ca587fb70d36574eb5.zip
adm5120: add 3.18 support
Signed-off-by: Rafał Miłecki <zajec5@gmail.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@44580 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/adm5120/patches-3.18/310-adm5120_wdt.patch')
-rw-r--r--target/linux/adm5120/patches-3.18/310-adm5120_wdt.patch31
1 files changed, 31 insertions, 0 deletions
diff --git a/target/linux/adm5120/patches-3.18/310-adm5120_wdt.patch b/target/linux/adm5120/patches-3.18/310-adm5120_wdt.patch
new file mode 100644
index 0000000000..4b6db8b8db
--- /dev/null
+++ b/target/linux/adm5120/patches-3.18/310-adm5120_wdt.patch
@@ -0,0 +1,31 @@
+--- a/drivers/watchdog/Kconfig
++++ b/drivers/watchdog/Kconfig
+@@ -1116,6 +1116,18 @@ config RC32434_WDT
+ To compile this driver as a module, choose M here: the
+ module will be called rc32434_wdt.
+
++config ADM5120_WDT
++ tristate "Infineon ADM5120 SoC hardware watchdog"
++ depends on WATCHDOG && ADM5120
++ help
++ This is a driver for hardware watchdog integrated in Infineon
++ ADM5120 SoC. This watchdog simply watches your kernel to make sure
++ it doesn't freeze, and if it does, it reboots your computer after a
++ certain amount of time.
++
++ To compile this driver as a module, choose M here: the module will be
++ called adm5120_wdt.
++
+ config INDYDOG
+ tristate "Indy/I2 Hardware Watchdog"
+ depends on SGI_HAS_INDYDOG
+--- a/drivers/watchdog/Makefile
++++ b/drivers/watchdog/Makefile
+@@ -131,6 +131,7 @@ obj-$(CONFIG_ATH79_WDT) += ath79_wdt.o
+ obj-$(CONFIG_BCM47XX_WDT) += bcm47xx_wdt.o
+ obj-$(CONFIG_BCM63XX_WDT) += bcm63xx_wdt.o
+ obj-$(CONFIG_RC32434_WDT) += rc32434_wdt.o
++obj-$(CONFIG_ADM5120_WDT) += adm5120_wdt.o
+ obj-$(CONFIG_INDYDOG) += indydog.o
+ obj-$(CONFIG_JZ4740_WDT) += jz4740_wdt.o
+ obj-$(CONFIG_WDT_MTX1) += mtx-1_wdt.o