aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/adm5120/patches-3.18/007-adm5120_pci.patch
diff options
context:
space:
mode:
authorRafał Miłecki <zajec5@gmail.com>2015-02-28 23:39:14 +0000
committerRafał Miłecki <zajec5@gmail.com>2015-02-28 23:39:14 +0000
commit7140ca235c2badffbea119ca587fb70d36574eb5 (patch)
tree79decc4c48d20eb458f033e07b55d7c0f37a7315 /target/linux/adm5120/patches-3.18/007-adm5120_pci.patch
parent4269bcdf04027fa9a724b107a457f7c508c3a3d0 (diff)
downloadupstream-7140ca235c2badffbea119ca587fb70d36574eb5.tar.gz
upstream-7140ca235c2badffbea119ca587fb70d36574eb5.tar.bz2
upstream-7140ca235c2badffbea119ca587fb70d36574eb5.zip
adm5120: add 3.18 support
Signed-off-by: Rafał Miłecki <zajec5@gmail.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@44580 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/adm5120/patches-3.18/007-adm5120_pci.patch')
-rw-r--r--target/linux/adm5120/patches-3.18/007-adm5120_pci.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/target/linux/adm5120/patches-3.18/007-adm5120_pci.patch b/target/linux/adm5120/patches-3.18/007-adm5120_pci.patch
new file mode 100644
index 0000000000..a5a0abf43b
--- /dev/null
+++ b/target/linux/adm5120/patches-3.18/007-adm5120_pci.patch
@@ -0,0 +1,22 @@
+--- a/arch/mips/pci/Makefile
++++ b/arch/mips/pci/Makefile
+@@ -18,6 +18,7 @@ obj-$(CONFIG_PCI_TX4927) += ops-tx4927.o
+ obj-$(CONFIG_BCM47XX) += pci-bcm47xx.o
+ obj-$(CONFIG_BCM63XX) += pci-bcm63xx.o fixup-bcm63xx.o \
+ ops-bcm63xx.o
++obj-$(CONFIG_ADM5120) += pci-adm5120.o
+ obj-$(CONFIG_MIPS_ALCHEMY) += pci-alchemy.o
+ obj-$(CONFIG_SOC_AR71XX) += pci-ar71xx.o
+ obj-$(CONFIG_PCI_AR724X) += pci-ar724x.o
+--- a/include/linux/pci_ids.h
++++ b/include/linux/pci_ids.h
+@@ -1820,6 +1820,9 @@
+
+ #define PCI_VENDOR_ID_CB 0x1307 /* Measurement Computing */
+
++#define PCI_VENDOR_ID_ADMTEK 0x1317
++#define PCI_DEVICE_ID_ADMTEK_ADM5120 0x5120
++
+ #define PCI_VENDOR_ID_SIIG 0x131f
+ #define PCI_SUBVENDOR_ID_SIIG 0x131f
+ #define PCI_DEVICE_ID_SIIG_1S_10x_550 0x1000