aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/adm5120/patches-3.14/005-adm5120_usb.patch
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2015-01-10 18:10:04 +0000
committerFlorian Fainelli <florian@openwrt.org>2015-01-10 18:10:04 +0000
commit3b21b2ae00c8e354db1789f8be5235a8fcb7a623 (patch)
tree379f0d688f6caf3cd9a33056dbca9362c1f36b7a /target/linux/adm5120/patches-3.14/005-adm5120_usb.patch
parentc119814b2bf25bc89a5cbfb3eb791ad7461d0c38 (diff)
downloadupstream-3b21b2ae00c8e354db1789f8be5235a8fcb7a623.tar.gz
upstream-3b21b2ae00c8e354db1789f8be5235a8fcb7a623.tar.bz2
upstream-3b21b2ae00c8e354db1789f8be5235a8fcb7a623.zip
adm5120: add experimental 3.14 kernel support
Signed-off-by: Florian Fainelli <florian@openwrt.org> SVN-Revision: 43915
Diffstat (limited to 'target/linux/adm5120/patches-3.14/005-adm5120_usb.patch')
-rw-r--r--target/linux/adm5120/patches-3.14/005-adm5120_usb.patch33
1 files changed, 33 insertions, 0 deletions
diff --git a/target/linux/adm5120/patches-3.14/005-adm5120_usb.patch b/target/linux/adm5120/patches-3.14/005-adm5120_usb.patch
new file mode 100644
index 0000000000..2a6846d3e6
--- /dev/null
+++ b/target/linux/adm5120/patches-3.14/005-adm5120_usb.patch
@@ -0,0 +1,33 @@
+--- a/drivers/usb/Makefile
++++ b/drivers/usb/Makefile
+@@ -12,6 +12,7 @@ obj-$(CONFIG_USB_DWC2) += dwc2/
+ obj-$(CONFIG_USB_MON) += mon/
+
+ obj-$(CONFIG_PCI) += host/
++obj-$(CONFIG_USB_ADM5120_HCD) += host/
+ obj-$(CONFIG_USB_EHCI_HCD) += host/
+ obj-$(CONFIG_USB_ISP116X_HCD) += host/
+ obj-$(CONFIG_USB_OHCI_HCD) += host/
+--- a/drivers/usb/host/Kconfig
++++ b/drivers/usb/host/Kconfig
+@@ -3,6 +3,10 @@
+ #
+ comment "USB Host Controller Drivers"
+
++config USB_ADM5120_HCD
++ tristate "ADM5120 HCD support (EXPERIMENTAL)"
++ depends on USB && ADM5120 && EXPERIMENTAL
++
+ config USB_C67X00_HCD
+ tristate "Cypress C67x00 HCD support"
+ help
+--- a/drivers/usb/host/Makefile
++++ b/drivers/usb/host/Makefile
+@@ -25,6 +25,7 @@ obj-$(CONFIG_USB_WHCI_HCD) += whci/
+
+ obj-$(CONFIG_PCI) += pci-quirks.o
+
++obj-$(CONFIG_USB_ADM5120_HCD) += adm5120-hcd.o
+ obj-$(CONFIG_USB_EHCI_HCD) += ehci-hcd.o
+ obj-$(CONFIG_USB_EHCI_PCI) += ehci-pci.o
+ obj-$(CONFIG_USB_EHCI_HCD_PLATFORM) += ehci-platform.o