aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/adm5120/patches-2.6.38/103-mtd_trxsplit.patch
diff options
context:
space:
mode:
authorAlexandros C. Couloumbis <alex@ozo.com>2011-04-13 16:42:03 +0000
committerAlexandros C. Couloumbis <alex@ozo.com>2011-04-13 16:42:03 +0000
commit54d4dc56c50063e373c149495fed6809af6118fa (patch)
treec04bb2686eb473e1caeca1bad90f524a1ac222f2 /target/linux/adm5120/patches-2.6.38/103-mtd_trxsplit.patch
parent8ba2d8098a03edbc1b8cc9990be8977c98267e05 (diff)
downloadupstream-54d4dc56c50063e373c149495fed6809af6118fa.tar.gz
upstream-54d4dc56c50063e373c149495fed6809af6118fa.tar.bz2
upstream-54d4dc56c50063e373c149495fed6809af6118fa.zip
linux/adm5120: add 2.6.38 preliminary support
SVN-Revision: 26647
Diffstat (limited to 'target/linux/adm5120/patches-2.6.38/103-mtd_trxsplit.patch')
-rw-r--r--target/linux/adm5120/patches-2.6.38/103-mtd_trxsplit.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/target/linux/adm5120/patches-2.6.38/103-mtd_trxsplit.patch b/target/linux/adm5120/patches-2.6.38/103-mtd_trxsplit.patch
new file mode 100644
index 0000000000..6992c9c53c
--- /dev/null
+++ b/target/linux/adm5120/patches-2.6.38/103-mtd_trxsplit.patch
@@ -0,0 +1,24 @@
+--- a/drivers/mtd/Kconfig
++++ b/drivers/mtd/Kconfig
+@@ -65,6 +65,11 @@ config MTD_ROOTFS_SPLIT
+ depends on MTD_PARTITIONS
+ default y
+
++config MTD_TRXSPLIT
++ bool "Automatically find and split TRX partitions"
++ depends on MTD_PARTITIONS
++ default n
++
+ config MTD_REDBOOT_PARTS
+ tristate "RedBoot partition table parsing"
+ ---help---
+--- a/drivers/mtd/Makefile
++++ b/drivers/mtd/Makefile
+@@ -9,6 +9,7 @@ mtd-$(CONFIG_MTD_PARTITIONS) += mtdpart.
+ mtd-$(CONFIG_MTD_OF_PARTS) += ofpart.o
+
+ obj-$(CONFIG_MTD_CONCAT) += mtdconcat.o
++obj-$(CONFIG_MTD_TRXSPLIT) += trxsplit.o
+ obj-$(CONFIG_MTD_REDBOOT_PARTS) += redboot.o
+ obj-$(CONFIG_MTD_CMDLINE_PARTS) += cmdlinepart.o
+ obj-$(CONFIG_MTD_AFS_PARTS) += afs.o