aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/adm5120/patches-2.6.33/009-adm5120_leds_switch_trigger.patch
diff options
context:
space:
mode:
authorAlexandros C. Couloumbis <alex@ozo.com>2010-04-27 08:46:13 +0000
committerAlexandros C. Couloumbis <alex@ozo.com>2010-04-27 08:46:13 +0000
commit535270a5d43ad39e41c23272b5a2e8c654f9c7f7 (patch)
treeaa238bd29ae75fe2f49e391bbb1c60e934a6f8da /target/linux/adm5120/patches-2.6.33/009-adm5120_leds_switch_trigger.patch
parentc3849fdfbdcab7486a1004833cb3594548f18b77 (diff)
downloadupstream-535270a5d43ad39e41c23272b5a2e8c654f9c7f7.tar.gz
upstream-535270a5d43ad39e41c23272b5a2e8c654f9c7f7.tar.bz2
upstream-535270a5d43ad39e41c23272b5a2e8c654f9c7f7.zip
adm5120: add 2.6.33 & 2.6.34 kernel support
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@21182 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/adm5120/patches-2.6.33/009-adm5120_leds_switch_trigger.patch')
-rw-r--r--target/linux/adm5120/patches-2.6.33/009-adm5120_leds_switch_trigger.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/target/linux/adm5120/patches-2.6.33/009-adm5120_leds_switch_trigger.patch b/target/linux/adm5120/patches-2.6.33/009-adm5120_leds_switch_trigger.patch
new file mode 100644
index 0000000000..5dc9a28503
--- /dev/null
+++ b/target/linux/adm5120/patches-2.6.33/009-adm5120_leds_switch_trigger.patch
@@ -0,0 +1,22 @@
+--- a/drivers/leds/Kconfig
++++ b/drivers/leds/Kconfig
+@@ -348,4 +348,12 @@ config LEDS_TRIGGER_NETDEV
+ This allows LEDs to be controlled by network device activity.
+ If unsure, say Y.
+
++config LEDS_TRIGGER_ADM5120_SWITCH
++ tristate "LED ADM5120 Switch Port Status Trigger"
++ depends on LEDS_TRIGGERS && ADM5120
++ help
++ This allows LEDs to be controlled by the port states of
++ the ADM5120 built-in Ethernet Switch
++ If unsure, say N.
++
+ endif # NEW_LEDS
+--- a/drivers/leds/Makefile
++++ b/drivers/leds/Makefile
+@@ -46,3 +46,4 @@ obj-$(CONFIG_LEDS_TRIGGER_GPIO) += ledt
+ obj-$(CONFIG_LEDS_TRIGGER_DEFAULT_ON) += ledtrig-default-on.o
+ obj-$(CONFIG_LEDS_TRIGGER_MORSE) += ledtrig-morse.o
+ obj-$(CONFIG_LEDS_TRIGGER_NETDEV) += ledtrig-netdev.o
++obj-$(CONFIG_LEDS_TRIGGER_ADM5120_SWITCH) += ledtrig-adm5120-switch.o