aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/adm5120/patches-2.6.28/007-adm5120_pci.patch
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2009-01-25 21:04:15 +0000
committerGabor Juhos <juhosg@openwrt.org>2009-01-25 21:04:15 +0000
commit4e8b080d9f7819ee9bb77cdb8215462acc1759f9 (patch)
treeefad7bd1b41a2d96ff842eaa6ef2c5f241ff943d /target/linux/adm5120/patches-2.6.28/007-adm5120_pci.patch
parent9a74dd2faae85d00c5e669fce947aec8eb1f0dfb (diff)
downloadupstream-4e8b080d9f7819ee9bb77cdb8215462acc1759f9.tar.gz
upstream-4e8b080d9f7819ee9bb77cdb8215462acc1759f9.tar.bz2
upstream-4e8b080d9f7819ee9bb77cdb8215462acc1759f9.zip
preliminary support for 2.6.28 (based on the patches by Alexandros C. Couloumbis)
SVN-Revision: 14189
Diffstat (limited to 'target/linux/adm5120/patches-2.6.28/007-adm5120_pci.patch')
-rw-r--r--target/linux/adm5120/patches-2.6.28/007-adm5120_pci.patch19
1 files changed, 19 insertions, 0 deletions
diff --git a/target/linux/adm5120/patches-2.6.28/007-adm5120_pci.patch b/target/linux/adm5120/patches-2.6.28/007-adm5120_pci.patch
new file mode 100644
index 0000000000..c3e0bea2d6
--- /dev/null
+++ b/target/linux/adm5120/patches-2.6.28/007-adm5120_pci.patch
@@ -0,0 +1,19 @@
+--- a/arch/mips/pci/Makefile
++++ b/arch/mips/pci/Makefile
+@@ -52,3 +52,4 @@ obj-$(CONFIG_VICTOR_MPC30X) += fixup-mpc
+ obj-$(CONFIG_ZAO_CAPCELLA) += fixup-capcella.o
+ obj-$(CONFIG_WR_PPMC) += fixup-wrppmc.o
+ obj-$(CONFIG_MIKROTIK_RB532) += pci-rc32434.o ops-rc32434.o fixup-rc32434.o
++obj-$(CONFIG_ADM5120) += pci-adm5120.o
+--- a/include/linux/pci_ids.h
++++ b/include/linux/pci_ids.h
+@@ -1723,6 +1723,9 @@
+ #define PCI_VENDOR_ID_ESDGMBH 0x12fe
+ #define PCI_DEVICE_ID_ESDGMBH_CPCIASIO4 0x0111
+
++#define PCI_VENDOR_ID_ADMTEK 0x1317
++#define PCI_DEVICE_ID_ADMTEK_ADM5120 0x5120
++
+ #define PCI_VENDOR_ID_SIIG 0x131f
+ #define PCI_SUBVENDOR_ID_SIIG 0x131f
+ #define PCI_DEVICE_ID_SIIG_1S_10x_550 0x1000