aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/adm5120/patches-2.6.24/009-adm5120_leds_switch_trigger.patch
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2008-01-30 15:25:48 +0000
committerGabor Juhos <juhosg@openwrt.org>2008-01-30 15:25:48 +0000
commit128bb0967a612a4359d29173f4d11a1716e5bf2a (patch)
treed4aa6c5844db9d0bef508776694aac64ebe22352 /target/linux/adm5120/patches-2.6.24/009-adm5120_leds_switch_trigger.patch
parent9bfca5ce18c5d02afc66a1c61fd85288d7af5d9e (diff)
downloadupstream-128bb0967a612a4359d29173f4d11a1716e5bf2a.tar.gz
upstream-128bb0967a612a4359d29173f4d11a1716e5bf2a.tar.bz2
upstream-128bb0967a612a4359d29173f4d11a1716e5bf2a.zip
add preliminary support for 2.6.24
SVN-Revision: 10329
Diffstat (limited to 'target/linux/adm5120/patches-2.6.24/009-adm5120_leds_switch_trigger.patch')
-rw-r--r--target/linux/adm5120/patches-2.6.24/009-adm5120_leds_switch_trigger.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/target/linux/adm5120/patches-2.6.24/009-adm5120_leds_switch_trigger.patch b/target/linux/adm5120/patches-2.6.24/009-adm5120_leds_switch_trigger.patch
new file mode 100644
index 0000000000..60b78ebf73
--- /dev/null
+++ b/target/linux/adm5120/patches-2.6.24/009-adm5120_leds_switch_trigger.patch
@@ -0,0 +1,26 @@
+Index: linux-2.6.24/drivers/leds/Kconfig
+===================================================================
+--- linux-2.6.24.orig/drivers/leds/Kconfig
++++ linux-2.6.24/drivers/leds/Kconfig
+@@ -171,4 +171,12 @@ config LEDS_TRIGGER_MORSE
+ tristate "LED Morse Trigger"
+ depends on LEDS_TRIGGERS
+
++config LEDS_TRIGGER_ADM5120_SWITCH
++ tristate "LED ADM5120 Switch Port Status Trigger"
++ depends on LEDS_TRIGGERS && LEDS_ADM5120
++ help
++ This allows LEDs to be controlled by the port states of
++ the ADM5120 built-in Ethernet Switch
++ If unsure, say N.
++
+ endif # NEW_LEDS
+Index: linux-2.6.24/drivers/leds/Makefile
+===================================================================
+--- linux-2.6.24.orig/drivers/leds/Makefile
++++ linux-2.6.24/drivers/leds/Makefile
+@@ -27,3 +27,4 @@ obj-$(CONFIG_LEDS_TRIGGER_TIMER) += ledt
+ obj-$(CONFIG_LEDS_TRIGGER_IDE_DISK) += ledtrig-ide-disk.o
+ obj-$(CONFIG_LEDS_TRIGGER_HEARTBEAT) += ledtrig-heartbeat.o
+ obj-$(CONFIG_LEDS_TRIGGER_MORSE) += ledtrig-morse.o
++obj-$(CONFIG_LEDS_TRIGGER_ADM5120_SWITCH) += ledtrig-adm5120-switch.o