aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/adm5120/patches-2.6.23/008-adm5120_uart.patch
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2007-10-11 07:45:02 +0000
committerGabor Juhos <juhosg@openwrt.org>2007-10-11 07:45:02 +0000
commit1f802675efe51029912d6c2391b054011e93abe0 (patch)
tree0aeb211ac98d1d7cb63286f7acf13a1bd1a6e6b1 /target/linux/adm5120/patches-2.6.23/008-adm5120_uart.patch
parent36c579aee3a396ab21336ebaa09c4a666267973c (diff)
downloadupstream-1f802675efe51029912d6c2391b054011e93abe0.tar.gz
upstream-1f802675efe51029912d6c2391b054011e93abe0.tar.bz2
upstream-1f802675efe51029912d6c2391b054011e93abe0.zip
prepare for 2.6.23
SVN-Revision: 9258
Diffstat (limited to 'target/linux/adm5120/patches-2.6.23/008-adm5120_uart.patch')
-rw-r--r--target/linux/adm5120/patches-2.6.23/008-adm5120_uart.patch53
1 files changed, 53 insertions, 0 deletions
diff --git a/target/linux/adm5120/patches-2.6.23/008-adm5120_uart.patch b/target/linux/adm5120/patches-2.6.23/008-adm5120_uart.patch
new file mode 100644
index 0000000000..cba437485c
--- /dev/null
+++ b/target/linux/adm5120/patches-2.6.23/008-adm5120_uart.patch
@@ -0,0 +1,53 @@
+Index: linux-2.6.23/drivers/serial/Makefile
+===================================================================
+--- linux-2.6.23.orig/drivers/serial/Makefile
++++ linux-2.6.23/drivers/serial/Makefile
+@@ -21,6 +21,7 @@ obj-$(CONFIG_SERIAL_8250_EXAR_ST16C554)
+ obj-$(CONFIG_SERIAL_8250_HUB6) += 8250_hub6.o
+ obj-$(CONFIG_SERIAL_8250_MCA) += 8250_mca.o
+ obj-$(CONFIG_SERIAL_8250_AU1X00) += 8250_au1x00.o
++obj-$(CONFIG_SERIAL_ADM5120) += adm5120_uart.o
+ obj-$(CONFIG_SERIAL_AMBA_PL010) += amba-pl010.o
+ obj-$(CONFIG_SERIAL_AMBA_PL011) += amba-pl011.o
+ obj-$(CONFIG_SERIAL_CLPS711X) += clps711x.o
+Index: linux-2.6.23/include/linux/serial_core.h
+===================================================================
+--- linux-2.6.23.orig/include/linux/serial_core.h
++++ linux-2.6.23/include/linux/serial_core.h
+@@ -147,6 +147,9 @@
+ #define PORT_SB1250_DUART 77
+
+
++/* ADMtek ADM5120 SoC */
++#define PORT_ADM5120 77
++
+ #ifdef __KERNEL__
+
+ #include <linux/compiler.h>
+Index: linux-2.6.23/drivers/serial/Kconfig
+===================================================================
+--- linux-2.6.23.orig/drivers/serial/Kconfig
++++ linux-2.6.23/drivers/serial/Kconfig
+@@ -280,6 +280,22 @@ config SERIAL_8250_RM9K
+
+ comment "Non-8250 serial port support"
+
++config SERIAL_ADM5120
++ bool "ADM5120 serial port support"
++ depends on MIPS_ADM5120
++ select SERIAL_CORE
++ select SERIAL_CORE_CONSOLE
++ help
++ Driver for the on chip UARTs on the ADM5120 SoC
++
++config ADM5120_NR_UARTS
++ int "Maximum number of ADM5120 serial ports"
++ depends on SERIAL_ADM5120
++ default "2"
++ ---help---
++ Set this to the number of serial ports you want the driver to
++ support.
++
+ config SERIAL_AMBA_PL010
+ tristate "ARM AMBA PL010 serial port support"
+ depends on ARM_AMBA && (BROKEN || !ARCH_VERSATILE)