aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/adm5120/patches-2.6.23/004-adm5120_nand.patch
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2007-10-11 07:45:02 +0000
committerGabor Juhos <juhosg@openwrt.org>2007-10-11 07:45:02 +0000
commit1f802675efe51029912d6c2391b054011e93abe0 (patch)
tree0aeb211ac98d1d7cb63286f7acf13a1bd1a6e6b1 /target/linux/adm5120/patches-2.6.23/004-adm5120_nand.patch
parent36c579aee3a396ab21336ebaa09c4a666267973c (diff)
downloadupstream-1f802675efe51029912d6c2391b054011e93abe0.tar.gz
upstream-1f802675efe51029912d6c2391b054011e93abe0.tar.bz2
upstream-1f802675efe51029912d6c2391b054011e93abe0.zip
prepare for 2.6.23
SVN-Revision: 9258
Diffstat (limited to 'target/linux/adm5120/patches-2.6.23/004-adm5120_nand.patch')
-rw-r--r--target/linux/adm5120/patches-2.6.23/004-adm5120_nand.patch33
1 files changed, 33 insertions, 0 deletions
diff --git a/target/linux/adm5120/patches-2.6.23/004-adm5120_nand.patch b/target/linux/adm5120/patches-2.6.23/004-adm5120_nand.patch
new file mode 100644
index 0000000000..ac9081142a
--- /dev/null
+++ b/target/linux/adm5120/patches-2.6.23/004-adm5120_nand.patch
@@ -0,0 +1,33 @@
+Index: linux-2.6.23/drivers/mtd/nand/Kconfig
+===================================================================
+--- linux-2.6.23.orig/drivers/mtd/nand/Kconfig
++++ linux-2.6.23/drivers/mtd/nand/Kconfig
+@@ -81,6 +81,16 @@ config MTD_NAND_TS7250
+ help
+ Support for NAND flash on Technologic Systems TS-7250 platform.
+
++config MTD_NAND_ADM5120
++ tristate "ADM5120 NAND support"
++ depends on MTD_NAND && MIPS_ADM5120
++ help
++ This enables the driver for the ADM5120 SoC built-in
++ NAND flash interface.
++
++ No board specific support is done by this driver, each board
++ must advertise a platform_device for the driver to attach.
++
+ config MTD_NAND_IDS
+ tristate
+
+Index: linux-2.6.23/drivers/mtd/nand/Makefile
+===================================================================
+--- linux-2.6.23.orig/drivers/mtd/nand/Makefile
++++ linux-2.6.23/drivers/mtd/nand/Makefile
+@@ -10,6 +10,7 @@ obj-$(CONFIG_MTD_NAND_CAFE) += cafe_nan
+ obj-$(CONFIG_MTD_NAND_SPIA) += spia.o
+ obj-$(CONFIG_MTD_NAND_AMS_DELTA) += ams-delta.o
+ obj-$(CONFIG_MTD_NAND_TOTO) += toto.o
++obj-$(CONFIG_MTD_NAND_ADM5120) += adm5120-nand.o
+ obj-$(CONFIG_MTD_NAND_AUTCPU12) += autcpu12.o
+ obj-$(CONFIG_MTD_NAND_EDB7312) += edb7312.o
+ obj-$(CONFIG_MTD_NAND_AU1550) += au1550nd.o