aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/adm5120/patches-2.6.22/008-adm5120_uart.patch
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-09-06 16:27:37 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-09-06 16:27:37 +0000
commit92558d67a463bfbb351d30e28648de03b635f024 (patch)
treea5d41b991a151e72663527a96fbc6c494565d65c /target/linux/adm5120/patches-2.6.22/008-adm5120_uart.patch
parente1dbce411cd2a3a067f387cee011cd889486a07d (diff)
downloadupstream-92558d67a463bfbb351d30e28648de03b635f024.tar.gz
upstream-92558d67a463bfbb351d30e28648de03b635f024.tar.bz2
upstream-92558d67a463bfbb351d30e28648de03b635f024.zip
strip the kernel version suffix from target directories, except for brcm-2.4 (the -2.4 will be included in the board name here). CONFIG_LINUX_<ver>_<board> becomes CONFIG_TARGET_<board>, same for profiles.
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@8653 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/adm5120/patches-2.6.22/008-adm5120_uart.patch')
-rw-r--r--target/linux/adm5120/patches-2.6.22/008-adm5120_uart.patch53
1 files changed, 53 insertions, 0 deletions
diff --git a/target/linux/adm5120/patches-2.6.22/008-adm5120_uart.patch b/target/linux/adm5120/patches-2.6.22/008-adm5120_uart.patch
new file mode 100644
index 0000000000..7f8451324d
--- /dev/null
+++ b/target/linux/adm5120/patches-2.6.22/008-adm5120_uart.patch
@@ -0,0 +1,53 @@
+Index: linux-2.6.22.1/drivers/serial/Makefile
+===================================================================
+--- linux-2.6.22.1.orig/drivers/serial/Makefile
++++ linux-2.6.22.1/drivers/serial/Makefile
+@@ -21,6 +21,7 @@ obj-$(CONFIG_SERIAL_8250_EXAR_ST16C554)
+ obj-$(CONFIG_SERIAL_8250_HUB6) += 8250_hub6.o
+ obj-$(CONFIG_SERIAL_8250_MCA) += 8250_mca.o
+ obj-$(CONFIG_SERIAL_8250_AU1X00) += 8250_au1x00.o
++obj-$(CONFIG_SERIAL_ADM5120) += adm5120_uart.o
+ obj-$(CONFIG_SERIAL_AMBA_PL010) += amba-pl010.o
+ obj-$(CONFIG_SERIAL_AMBA_PL011) += amba-pl011.o
+ obj-$(CONFIG_SERIAL_CLPS711X) += clps711x.o
+Index: linux-2.6.22.1/include/linux/serial_core.h
+===================================================================
+--- linux-2.6.22.1.orig/include/linux/serial_core.h
++++ linux-2.6.22.1/include/linux/serial_core.h
+@@ -143,6 +143,9 @@
+ #define PORT_KS8695 76
+
+
++/* ADMtek ADM5120 SoC */
++#define PORT_ADM5120 77
++
+ #ifdef __KERNEL__
+
+ #include <linux/compiler.h>
+Index: linux-2.6.22.1/drivers/serial/Kconfig
+===================================================================
+--- linux-2.6.22.1.orig/drivers/serial/Kconfig
++++ linux-2.6.22.1/drivers/serial/Kconfig
+@@ -270,6 +270,22 @@ config SERIAL_8250_RM9K
+
+ comment "Non-8250 serial port support"
+
++config SERIAL_ADM5120
++ bool "ADM5120 serial port support"
++ depends on MIPS_ADM5120
++ select SERIAL_CORE
++ select SERIAL_CORE_CONSOLE
++ help
++ Driver for the on chip UARTs on the ADM5120 SoC
++
++config ADM5120_NR_UARTS
++ int "Maximum number of ADM5120 serial ports"
++ depends on SERIAL_ADM5120
++ default "2"
++ ---help---
++ Set this to the number of serial ports you want the driver to
++ support.
++
+ config SERIAL_AMBA_PL010
+ tristate "ARM AMBA PL010 serial port support"
+ depends on ARM_AMBA && (BROKEN || !ARCH_VERSATILE)