aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2005-08-14 15:56:01 +0000
committerFelix Fietkau <nbd@openwrt.org>2005-08-14 15:56:01 +0000
commit89a7b6b69a7be5f81bba7df3e4a0b285f26d9f40 (patch)
tree511f5c1fc24819f32cb3b125f605b359664fb7c1 /target/linux/Makefile
parentcd64856ad022b992a7363068a739af0b22700550 (diff)
downloadupstream-89a7b6b69a7be5f81bba7df3e4a0b285f26d9f40.tar.gz
upstream-89a7b6b69a7be5f81bba7df3e4a0b285f26d9f40.tar.bz2
upstream-89a7b6b69a7be5f81bba7df3e4a0b285f26d9f40.zip
fix image builder dependency problem
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@1664 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/Makefile')
-rw-r--r--target/linux/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/target/linux/Makefile b/target/linux/Makefile
index 610bc7e1b4..4c17a57881 100644
--- a/target/linux/Makefile
+++ b/target/linux/Makefile
@@ -36,11 +36,11 @@ clean: $(1)/$(2)-clean
prepare: $(1)/$(2)-prepare
compile: $(1)/$(2)-compile
rebuild: $(1)/$(2)-rebuild
-install: $(1)/$(2)-image
+$(BIN_DIR)/$(IB_NAME).tar.bz2 install: $(1)/$(2)-image
install-ib: $(1)/$(2)-install-ib
endif
-.PHONY: $(1)/$(2)-clean $(1)/$(2)-prepare $(1)/$(2)-compile $(1)/$(2)-rebuild $(1)/$(2)-install $(1)/$(2)-install-ib
+.PHONY: $(1)/$(2)-clean $(1)/$(2)-prepare $(1)/$(2)-compile $(1)/$(2)-rebuild $(1)/$(2)-install $(1)/$(2)-image $(1)/$(2)-install-ib
endef
.PHONY: clean prepare compile rebuild install imagebuilder install-ib