aboutsummaryrefslogtreecommitdiffstats
path: root/target/imagebuilder
diff options
context:
space:
mode:
authorMatthew Gyurgyik <matthew@gyurgyik.io>2020-11-13 11:21:29 -0800
committerPaul Spooren <mail@aparcar.org>2020-11-24 14:46:05 -1000
commitaab36200e7eb539afb18df74476132f4750a9f0b (patch)
tree2231b438d3ab73f09d6ea14c57342cdeee6bd628 /target/imagebuilder
parent89854d38349220bbbd9796ca59da4f4c551d5e99 (diff)
downloadupstream-aab36200e7eb539afb18df74476132f4750a9f0b.tar.gz
upstream-aab36200e7eb539afb18df74476132f4750a9f0b.tar.bz2
upstream-aab36200e7eb539afb18df74476132f4750a9f0b.zip
imagebuilder: fix partition signature
When building images with the imagebuilder, the partition signature never changes. The signature is generated by hashing SOURCE_DATE_EPOCH and LINUX_VERMAGIC which are undefined. Prepopulate these variables, as done by the SDK. Signed-off-by: Matthew Gyurgyik <matthew@gyurgyik.io>
Diffstat (limited to 'target/imagebuilder')
-rw-r--r--target/imagebuilder/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/target/imagebuilder/Makefile b/target/imagebuilder/Makefile
index a96f8618e8..e7954e96a4 100644
--- a/target/imagebuilder/Makefile
+++ b/target/imagebuilder/Makefile
@@ -89,6 +89,8 @@ endif
$(CP) -L $(LINUX_DIR)/arch/$(LINUX_KARCH)/boot/dts/* $(IB_DTSDIR); \
fi
$(SED) 's,^# REVISION:=.*,REVISION:=$(REVISION),g' $(PKG_BUILD_DIR)/include/version.mk
+ $(SED) 's,^# SOURCE_DATE_EPOCH:=.*,SOURCE_DATE_EPOCH:=$(SOURCE_DATE_EPOCH),g' $(PKG_BUILD_DIR)/include/version.mk
+ $(SED) '/LINUX_VERMAGIC:=/ { s,unknown,$(LINUX_VERMAGIC),g }' $(PKG_BUILD_DIR)/include/kernel.mk
find $(PKG_BUILD_DIR) -name CVS -o -name .git -o -name .svn \
| $(XARGS) rm -rf
$(INSTALL_DIR) $(IB_IDIR)