aboutsummaryrefslogtreecommitdiffstats
path: root/target/imagebuilder
diff options
context:
space:
mode:
authorDaniel Dickinson <openwrt@daniel.thecshore.com>2016-04-26 04:50:27 -0400
committerJo-Philipp Wich <jo@mein.io>2016-05-18 23:53:01 +0200
commit9fd8e55132ecfea717062c4f9ee91c79dbe4a427 (patch)
tree535da157613875127e62b36d229eecdbd8c865e0 /target/imagebuilder
parentd830cb08826dc593406d9003d061016061b6c3c4 (diff)
downloadupstream-9fd8e55132ecfea717062c4f9ee91c79dbe4a427.tar.gz
upstream-9fd8e55132ecfea717062c4f9ee91c79dbe4a427.tar.bz2
upstream-9fd8e55132ecfea717062c4f9ee91c79dbe4a427.zip
imagebuilder: Fix sorting package list breaks opkg dependency handling for provides
When imagebuild sorts package lists it breaks opkg's ability to realize that a providers for a Provides has already been installed, when the sort results in the provider being later in the list of packages that a package which depends on a Provides (and hence the provider is not yet installed for opkg to realize the provider was available doesn't not handle the case of a package that is to be installed satisfying a dependency, only one that is already installed (or which it schedules to be installed, which in the absence of an installed provider is whichever provider happens to be the default) Signed-off-by: Daniel Dickinson <openwrt@daniel.thecshore.com>
Diffstat (limited to 'target/imagebuilder')
-rw-r--r--target/imagebuilder/files/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/imagebuilder/files/Makefile b/target/imagebuilder/files/Makefile
index e0dc0b9cea..c5f8bd7681 100644
--- a/target/imagebuilder/files/Makefile
+++ b/target/imagebuilder/files/Makefile
@@ -104,7 +104,7 @@ _call_info: FORCE
echo 'Available Profiles:'
echo; $(PROFILE_LIST)
-BUILD_PACKAGES:=$(sort $(DEFAULT_PACKAGES) $(USER_PACKAGES) $($(USER_PROFILE)_PACKAGES) kernel)
+BUILD_PACKAGES:=$(USER_PACKAGES) $(sort $(DEFAULT_PACKAGES) $($(USER_PROFILE)_PACKAGES) kernel)
# "-pkgname" in the package list means remove "pkgname" from the package list
BUILD_PACKAGES:=$(filter-out $(filter -%,$(BUILD_PACKAGES)) $(patsubst -%,%,$(filter -%,$(BUILD_PACKAGES))),$(BUILD_PACKAGES))
PACKAGES:=