aboutsummaryrefslogtreecommitdiffstats
path: root/target/imagebuilder
diff options
context:
space:
mode:
authorPaul Spooren <mail@aparcar.org>2020-06-08 18:15:05 -1000
committerDaniel Golle <daniel@makrotopia.org>2020-06-11 11:12:56 +0100
commit941ec28b355ea690b5682d2bf8175aa513379997 (patch)
tree63b4ec1f474ade260b0a8e104f0c41630d1be8e8 /target/imagebuilder
parent4f3806364011aa3aef26fcab2e7b71837a777bcc (diff)
downloadupstream-941ec28b355ea690b5682d2bf8175aa513379997.tar.gz
upstream-941ec28b355ea690b5682d2bf8175aa513379997.tar.bz2
upstream-941ec28b355ea690b5682d2bf8175aa513379997.zip
imagebuilder: Remove json_info_files/ before build
The folder `json_info_files` contains multiple JSON files which describe created firmware images. The folder is not removed between builds as the ImageBuilder does not use `image.mk`. Not removing the JSON files result in a merged `profiles.json` file containing entries for outdated or non-existing images. This commit adds the `json_info_files/` cleanup step to the ImageBuilder Makefile. Signed-off-by: Paul Spooren <mail@aparcar.org>
Diffstat (limited to 'target/imagebuilder')
-rw-r--r--target/imagebuilder/files/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/target/imagebuilder/files/Makefile b/target/imagebuilder/files/Makefile
index 01e374856c..326dd2ba2f 100644
--- a/target/imagebuilder/files/Makefile
+++ b/target/imagebuilder/files/Makefile
@@ -168,6 +168,7 @@ prepare_rootfs: FORCE
build_image: FORCE
@echo
@echo Building images...
+ rm -rf $(BUILD_DIR)/json_info_files/
$(NO_TRACE_MAKE) -C target/linux/$(BOARD)/image install TARGET_BUILD=1 IB=1 EXTRA_IMAGE_NAME="$(EXTRA_IMAGE_NAME)" \
$(if $(USER_PROFILE),PROFILE="$(USER_PROFILE)")