aboutsummaryrefslogtreecommitdiffstats
path: root/target/imagebuilder
diff options
context:
space:
mode:
authorPaul Spooren <mail@aparcar.org>2020-08-20 15:44:51 -1000
committerDaniel Golle <daniel@makrotopia.org>2020-08-31 11:18:24 +0100
commit84024e245f346cdf1da955cea4ab4c2c0a0886b2 (patch)
tree58e99f67e53365351d7145a299e641e038999596 /target/imagebuilder
parent62d5ec7306f9664aeba64bc64c0dee1d93978bb4 (diff)
downloadupstream-84024e245f346cdf1da955cea4ab4c2c0a0886b2.tar.gz
upstream-84024e245f346cdf1da955cea4ab4c2c0a0886b2.tar.bz2
upstream-84024e245f346cdf1da955cea4ab4c2c0a0886b2.zip
build: add whatdepends target to imagebuilder
The package manager `opkg` offers the function `whatdepends` to print packages that depend on a specific package. This feature is useful when used in a CI to not only build an upgraded package but all packages with a dependency. Usage: make whatdepends PACKAGE=libipset The resulting list can be fed into a SDK building all packages and warn if anything fails. Signed-off-by: Paul Spooren <mail@aparcar.org>
Diffstat (limited to 'target/imagebuilder')
-rw-r--r--target/imagebuilder/files/Makefile10
1 files changed, 9 insertions, 1 deletions
diff --git a/target/imagebuilder/files/Makefile b/target/imagebuilder/files/Makefile
index 326dd2ba2f..27d3cfa8df 100644
--- a/target/imagebuilder/files/Makefile
+++ b/target/imagebuilder/files/Makefile
@@ -220,4 +220,12 @@ manifest: FORCE
$(if $(PROFILE),USER_PROFILE="$(PROFILE_FILTER)") \
$(if $(PACKAGES),USER_PACKAGES="$(PACKAGES)"))
-.SILENT: help info image manifest
+whatdepends: FORCE
+ifeq ($(PACKAGE),)
+ @echo 'Variable `PACKAGE` is not set but required by `whatdepends`'
+ @exit 1
+endif
+ @$(MAKE) -s package_reload
+ @$(OPKG) whatdepends -A $(PACKAGE)
+
+.SILENT: help info image manifest whatdepends