aboutsummaryrefslogtreecommitdiffstats
path: root/target/imagebuilder
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2016-07-21 13:41:20 +0200
committerFelix Fietkau <nbd@nbd.name>2016-07-21 13:41:20 +0200
commit8265fdcc4dda2554d4f7774e53020136079639b2 (patch)
treec7eaa39f84f1be818b845debb618f9a8fbeaee70 /target/imagebuilder
parented90d50bc4cbbcf615f880c1799814ccf743de8c (diff)
downloadupstream-8265fdcc4dda2554d4f7774e53020136079639b2.tar.gz
upstream-8265fdcc4dda2554d4f7774e53020136079639b2.tar.bz2
upstream-8265fdcc4dda2554d4f7774e53020136079639b2.zip
imagebuilder: strip DEVICE_ prefix from profiles (FS#55)
Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'target/imagebuilder')
-rw-r--r--target/imagebuilder/files/Makefile8
1 files changed, 5 insertions, 3 deletions
diff --git a/target/imagebuilder/files/Makefile b/target/imagebuilder/files/Makefile
index 64f21b8871..4ae0297355 100644
--- a/target/imagebuilder/files/Makefile
+++ b/target/imagebuilder/files/Makefile
@@ -77,7 +77,7 @@ include $(INCLUDE_DIR)/target.mk
USER_PROFILE ?= $(firstword $(PROFILE_NAMES))
PROFILE_LIST = $(foreach p,$(PROFILE_NAMES), \
- echo '$(p):'; $(if $($(p)_NAME),echo ' $($(p)_NAME)'; ) echo ' Packages: $($(p)_PACKAGES)'; \
+ echo '$(patsubst DEVICE_%,%,$(p)):'; $(if $($(p)_NAME),echo ' $($(p)_NAME)'; ) echo ' Packages: $($(p)_PACKAGES)'; \
)
.profiles.mk: .targetinfo
@@ -180,9 +180,11 @@ clean:
info:
(unset PROFILE FILES PACKAGES MAKEFLAGS; $(MAKE) -s _call_info)
+PROFILE_FILTER = $(filter DEVICE_$(PROFILE) $(PROFILE),$(PROFILE_NAMES))
+
image:
ifneq ($(PROFILE),)
- ifeq ($(filter $(PROFILE),$(PROFILE_NAMES)),)
+ ifeq ($(PROFILE_FILTER),)
@echo 'Profile "$(PROFILE)" does not exist!'
@echo 'Use "make info" to get a list of available profile names.'
@exit 1
@@ -190,7 +192,7 @@ ifneq ($(PROFILE),)
endif
(unset PROFILE FILES PACKAGES MAKEFLAGS; \
$(MAKE) _call_image \
- $(if $(PROFILE),USER_PROFILE="$(PROFILE)") \
+ $(if $(PROFILE),USER_PROFILE="$(PROFILE_FILTER)") \
$(if $(FILES),USER_FILES="$(FILES)") \
$(if $(PACKAGES),USER_PACKAGES="$(PACKAGES)") \
$(if $(BIN_DIR),BIN_DIR="$(BIN_DIR)"))