aboutsummaryrefslogtreecommitdiffstats
path: root/target/imagebuilder
diff options
context:
space:
mode:
authorDaniel Dickinson <lede@cshore.thecshore.com>2016-09-29 04:14:17 -0400
committerJohn Crispin <john@phrozen.org>2016-09-30 00:39:25 +0200
commit71370d2c5543b3073653b601aba26078fdbab682 (patch)
treef33ca57ac0c120f3c6e6de7bc7ec641a9eff8f21 /target/imagebuilder
parentc3d3111831d49d1ab37d90bbe6a61f1b2263721d (diff)
downloadupstream-71370d2c5543b3073653b601aba26078fdbab682.tar.gz
upstream-71370d2c5543b3073653b601aba26078fdbab682.tar.bz2
upstream-71370d2c5543b3073653b601aba26078fdbab682.zip
target/{sdk,imagebuild}: Fix for symlink-tree
With symlink tree some directories are just symlinked which means IB and SDK end up with a symlink instead of an actual directory; this fixes the missing files by dereferencesing the directories instead of copying the symlinks. Signed-off-by: Daniel Dickinson <lede@cshore.thecshore.com>
Diffstat (limited to 'target/imagebuilder')
-rw-r--r--target/imagebuilder/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/imagebuilder/Makefile b/target/imagebuilder/Makefile
index 4b61963b0a..b809193db3 100644
--- a/target/imagebuilder/Makefile
+++ b/target/imagebuilder/Makefile
@@ -26,7 +26,7 @@ $(BIN_DIR)/$(IB_NAME).tar.bz2: clean
mkdir -p $(IB_KDIR) $(IB_LDIR) $(PKG_BUILD_DIR)/staging_dir/host/lib \
$(PKG_BUILD_DIR)/target $(PKG_BUILD_DIR)/scripts $(IB_DTSDIR)
-cp $(TOPDIR)/.config $(PKG_BUILD_DIR)/.config
- $(CP) \
+ $(CP) -L \
$(INCLUDE_DIR) $(SCRIPT_DIR) \
$(TOPDIR)/rules.mk \
./files/Makefile \