aboutsummaryrefslogtreecommitdiffstats
path: root/target/imagebuilder
diff options
context:
space:
mode:
authorJo-Philipp Wich <jo@mein.io>2017-01-26 10:13:23 +0100
committerJo-Philipp Wich <jo@mein.io>2017-01-26 10:16:32 +0100
commit6cb8e30837ce1bfff8c3c4e18bc8ccf8b4c2c8d5 (patch)
treeac152a0fd74e135bb9fb8c65cba47bd68e5b4c7c /target/imagebuilder
parentb94177e10fc72f9309eae7459c3570e5c080e960 (diff)
downloadupstream-6cb8e30837ce1bfff8c3c4e18bc8ccf8b4c2c8d5.tar.gz
upstream-6cb8e30837ce1bfff8c3c4e18bc8ccf8b4c2c8d5.tar.bz2
upstream-6cb8e30837ce1bfff8c3c4e18bc8ccf8b4c2c8d5.zip
imagebuilder: properly escape single quotes in device titles
The name "Plat'Home OpenBlocks AX3" causes the imagebuilders "make info" command to fail with: bash: -c: line 0: syntax error near unexpected token `(' bash: -c: line 0: `echo; [...]' Makefile:99: recipe for target '_call_info' failed Properly escape single quotes to avoid breaking the echo commands. Signed-off-by: Jo-Philipp Wich <jo@mein.io>
Diffstat (limited to 'target/imagebuilder')
-rw-r--r--target/imagebuilder/files/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/imagebuilder/files/Makefile b/target/imagebuilder/files/Makefile
index 493012ff72..af633b2163 100644
--- a/target/imagebuilder/files/Makefile
+++ b/target/imagebuilder/files/Makefile
@@ -74,7 +74,7 @@ include $(INCLUDE_DIR)/target.mk
USER_PROFILE ?= $(firstword $(PROFILE_NAMES))
PROFILE_LIST = $(foreach p,$(PROFILE_NAMES), \
- echo '$(patsubst DEVICE_%,%,$(p)):'; $(if $($(p)_NAME),echo ' $($(p)_NAME)'; ) echo ' Packages: $($(p)_PACKAGES)'; \
+ echo '$(patsubst DEVICE_%,%,$(p)):'; $(if $($(p)_NAME),echo ' $(subst ','"'"',$($(p)_NAME))'; ) echo ' Packages: $($(p)_PACKAGES)'; \
)
.profiles.mk: .targetinfo