aboutsummaryrefslogtreecommitdiffstats
path: root/target/imagebuilder
diff options
context:
space:
mode:
authorDaniel Engberg <diizzyy@users.noreply.github.com>2016-10-11 14:14:48 +0200
committerJohn Crispin <john@phrozen.org>2016-10-15 11:36:51 +0200
commit636a069c42b4c98e52fea949961cceccb8273b1f (patch)
tree419e3bea005c3a2007036675d6b6c4f9d2f5c249 /target/imagebuilder
parent195d2de867a65218ee49cc1049f4391f6b968b70 (diff)
downloadupstream-636a069c42b4c98e52fea949961cceccb8273b1f.tar.gz
upstream-636a069c42b4c98e52fea949961cceccb8273b1f.tar.bz2
upstream-636a069c42b4c98e52fea949961cceccb8273b1f.zip
target/imagebuilder: Switch to xz compression instead of bz2
Switch to xz compression instead of using bz2. Saves about 20% of total size (ar71xx) Signed-off-by: Daniel Engberg <daniel.engberg.lists@pyret.net>
Diffstat (limited to 'target/imagebuilder')
-rw-r--r--target/imagebuilder/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/target/imagebuilder/Makefile b/target/imagebuilder/Makefile
index b809193db3..b43662b6ac 100644
--- a/target/imagebuilder/Makefile
+++ b/target/imagebuilder/Makefile
@@ -21,7 +21,7 @@ IB_DTSDIR:=$(patsubst $(TOPDIR)/%,$(PKG_BUILD_DIR)/%,$(LINUX_DIR))/arch/$(ARCH)/
all: compile
-$(BIN_DIR)/$(IB_NAME).tar.bz2: clean
+$(BIN_DIR)/$(IB_NAME).tar.xz: clean
rm -rf $(PKG_BUILD_DIR)
mkdir -p $(IB_KDIR) $(IB_LDIR) $(PKG_BUILD_DIR)/staging_dir/host/lib \
$(PKG_BUILD_DIR)/target $(PKG_BUILD_DIR)/scripts $(IB_DTSDIR)
@@ -77,12 +77,12 @@ endif
find $(STAGING_DIR_HOST)/bin -maxdepth 1 -type f -perm -u=x \
| $(XARGS) $(SCRIPT_DIR)/bundle-libraries.sh $(PKG_BUILD_DIR)/staging_dir/host/bin/
STRIP=sstrip $(SCRIPT_DIR)/rstrip.sh $(PKG_BUILD_DIR)/staging_dir/host/bin/
- $(TAR) -cf - -C $(BUILD_DIR) $(IB_NAME) | bzip2 -c > $@
+ $(TAR) -cf - -C $(BUILD_DIR) $(IB_NAME) | xz -zc -7e > $@
download:
prepare:
-compile: $(BIN_DIR)/$(IB_NAME).tar.bz2
+compile: $(BIN_DIR)/$(IB_NAME).tar.xz
install: compile
clean: FORCE
- rm -rf $(PKG_BUILD_DIR) $(BIN_DIR)/$(IB_NAME).tar.bz2
+ rm -rf $(PKG_BUILD_DIR) $(BIN_DIR)/$(IB_NAME).tar.xz